summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHwankyu Jhun <h.jhun@samsung.com>2019-02-03 18:39:40 +0900
committerHwankyu Jhun <h.jhun@samsung.com>2019-02-18 21:37:29 +0900
commit4cb2e1286c9e314e4b819d96e44d49bfe24f443e (patch)
tree5376d23beb8777a69f88dddc1523154f68ef809a /CMakeLists.txt
parente04359fa6d8f7b6a8304c4e1a8d55badca74daf1 (diff)
downloadapp-core-4cb2e1286c9e314e4b819d96e44d49bfe24f443e.tar.gz
app-core-4cb2e1286c9e314e4b819d96e44d49bfe24f443e.tar.bz2
app-core-4cb2e1286c9e314e4b819d96e44d49bfe24f443e.zip
Support handling of each app-control ID
Requires: - https://review.tizen.org/gerrit/#/c/platform/core/appfw/aul-1/+/199252/ - https://review.tizen.org/gerrit/#/c/platform/core/appfw/app-core/+/199104/ - https://review.tizen.org/gerrit/#/c/platform/core/api/app-control/+/199105/ Change-Id: Ic02def5706302642d90c20a2f7bdde5700976f0e Signed-off-by: Hwankyu Jhun <h.jhun@samsung.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 17f4d5b..a85c605 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,12 +29,14 @@ SET(SRCS_common
src/legacy/appcore-rotation.c
src/legacy/appcore-i18n.c
src/base/appcore_base.c
+ src/base/appcore_base_control.c
src/watchdog/appcore_watchdog.c)
SET(HEADERS_common
appcore-common.h
appcore_base.h
- appcore_watchdog.h)
+ appcore_watchdog.h
+ appcore_base_control.h)
INCLUDE(FindPkgConfig)
SET(APPCORE_PKG_CHECK_MODULES "gio-2.0 vconf sensor aul dlog capi-system-info")