summaryrefslogtreecommitdiff
path: root/lib/list/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/list/CMakeLists.txt')
-rwxr-xr-xlib/list/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/lib/list/CMakeLists.txt b/lib/list/CMakeLists.txt
new file mode 100755
index 0000000..6aa7157
--- /dev/null
+++ b/lib/list/CMakeLists.txt
@@ -0,0 +1,15 @@
+LINK_DIRECTORIES(${CMAKE_BINARY_DIR})
+
+SET(TARGET ${CT_LIST})
+
+FILE(GLOB SRCS *.c)
+
+ADD_LIBRARY(${TARGET} SHARED ${SRCS})
+SET_TARGET_PROPERTIES(${TARGET} PROPERTIES SOVERSION ${VERSION_MAJOR})
+SET_TARGET_PROPERTIES(${TARGET} PROPERTIES VERSION ${VERSION})
+
+SET_TARGET_PROPERTIES(${TARGET} PROPERTIES COMPILE_FLAGS ${EXTRA_CFLAGS})
+TARGET_LINK_LIBRARIES(${TARGET} ${COMMON_LIB} ${ug_pkgs_LDFLAGS} ug-contacts-details-efl)
+
+ADD_DEPENDENCIES(${TARGET} contacts_edj_build contacts_theme_build)
+INSTALL(TARGETS ${TARGET} DESTINATION ${UGLIBDIR})