summaryrefslogtreecommitdiff
path: root/driver/Makefile.am
diff options
context:
space:
mode:
authorVyacheslav Cherkashin <v.cherkashin@samsung.com>2013-03-28 11:40:16 +0400
committerVyacheslav Cherkashin <v.cherkashin@samsung.com>2013-03-28 12:47:31 +0400
commite40586aab17b20dd097678107fb15313d122e918 (patch)
tree4313938b1721e58ff7242c1c8095bb94a8150e43 /driver/Makefile.am
parentc81377136240ec005c34a6724e55fee32ee4f629 (diff)
downloadswap-modules-e40586aab17b20dd097678107fb15313d122e918.tar.gz
swap-modules-e40586aab17b20dd097678107fb15313d122e918.tar.bz2
swap-modules-e40586aab17b20dd097678107fb15313d122e918.zip
[REFACTOR] rename and move arch_disarm_uprobe()
rename: arch_disarm_uprobe() --> disarm_uprobe() move: from src/modules/kprobe/arch/dbi_kprobes.c to src/modules/uprobe/swap_uprobes.c
Diffstat (limited to 'driver/Makefile.am')
-rw-r--r--driver/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/driver/Makefile.am b/driver/Makefile.am
index eead5418..730fdde9 100644
--- a/driver/Makefile.am
+++ b/driver/Makefile.am
@@ -33,7 +33,9 @@ driver_module_dir = $(realpath $(srcdir))
module_name = swap_driver
cross_compiler = $(subst gcc,,$(CC))
-inlude_opt = -I$(realpath $(top_srcdir)/src/modules/ksyms) -I$(realpath $(top_srcdir)/src/common) -I$(realpath $(top_srcdir)/src/profile) -I$(realpath $(top_srcdir)/src/modules/kprobe)
+inlude_opt = -I$(realpath $(top_srcdir)/src/modules/ksyms) -I$(realpath $(top_srcdir)/src/common) \
+ -I$(realpath $(top_srcdir)/src/profile) -I$(realpath $(top_srcdir)/src/modules/kprobe) \
+ -I$(realpath $(top_srcdir)/src/modules/uprobe)
extra_cflags = "$(inlude_opt) -DEC_ARCH_$(ARCH) -D__DEBUG $(memchecker) $(debug_opt) $(android_opt) $(slp_opt) $(android_app_opt) $(board_opt)"
#bin_SCRIPTS = patchko.sh insmod.sh