summaryrefslogtreecommitdiff
path: root/packaging/web-ui-fw.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/web-ui-fw.spec')
-rw-r--r--packaging/web-ui-fw.spec221
1 files changed, 204 insertions, 17 deletions
diff --git a/packaging/web-ui-fw.spec b/packaging/web-ui-fw.spec
index 8738e99c..0cb5ae8c 100644
--- a/packaging/web-ui-fw.spec
+++ b/packaging/web-ui-fw.spec
@@ -1,34 +1,221 @@
-Name: web-ui-fw
-Summary: Tizen Web UI Framework Library
-Version: 0.1.11
-Release: 1
-Group: TO_BE/FILLED_IN
-License: MIT
-BuildRequires: node-js, make
+Name: web-ui-fw
+Version: 0.1.38
+Release: 0
+Summary: Tizen Web UI Framework Library
+Group: Development/Other
+License: MIT
+BuildArch: noarch
+BuildRequires: make
+BuildRequires: nodejs
+%ifarch %{arm}
+BuildRequires: nodejs-x86-arm
+%endif
+
+Source0: %{name}-%{version}.tar.gz
%description
-Tizen Web UI Framework library package
+Tizen Web UI Framework library and theme packages
%prep
-make clean
+%setup -q
%build
-make
+make all
-%post
+%install
+make DESTDIR=%{buildroot} install
+%post
%files
-/usr/lib/tizen-web-ui-fw/*/js
-/usr/lib/tizen-web-ui-fw/*/themes/tizen-gray
+/usr/share/tizen-web-ui-fw/*/js
+/usr/share/tizen-web-ui-fw/latest
+
+###############################
+%package -n web-ui-fw-theme-tizen-gray
+BuildArch: noarch
+Summary: Tizen Web UI Framework Theme : tizen-gray
+%Description -n web-ui-fw-theme-tizen-gray
+ Tizen Web UI Framework Theme : tizen-gray
+%files -n web-ui-fw-theme-tizen-gray
+/usr/share/tizen-web-ui-fw/*/themes/tizen-gray
+
+###############################
+%package -n web-ui-fw-theme-tizen-white
+BuildArch: noarch
+Summary: Tizen Web UI Framework Theme : tizen-white
+%Description -n web-ui-fw-theme-tizen-white
+ Tizen Web UI Framework Theme : tizen-white
+%files -n web-ui-fw-theme-tizen-white
+/usr/share/tizen-web-ui-fw/*/themes/tizen-white
+
+###############################
+%package -n web-ui-fw-theme-default
+BuildArch: noarch
+Summary: Tizen Web UI Framework Theme : default
+%Description -n web-ui-fw-theme-default
+ Tizen Web UI Framework Theme : default
+%files -n web-ui-fw-theme-default
+/usr/share/tizen-web-ui-fw/*/themes/default
+
+###############################
+%package -n web-ui-fw-devel
+BuildArch: noarch
+Summary: Tizen Web UI Framework Developer's files
+%Description -n web-ui-fw-devel
+ Tizen Web UI Framework Developer's files
+%files -n web-ui-fw-devel
+/usr/share/tizen-web-ui-fw/bin
+/usr/share/tizen-web-ui-fw/template
+
+###############################
+%package -n web-ui-fw-demo-tizen-winsets
+BuildArch: noarch
+Summary: Tizen Web UI Framework Demo Application: tizen winset demo
+%Description -n web-ui-fw-demo-tizen-winsets
+ Tizen Web UI Framework Demo Application: tizen winset demo
+%files -n web-ui-fw-demo-tizen-winsets
+/usr/share/tizen-web-ui-fw/demos/tizen-winsets
+
+
+###############################
+%changelog
+
+* Mon Aug 20 2012 Minkyu Kang <mk7.kang@samasung.com> 0.1.38
+- FIX:
+ - fix coment of version tag
+
+* Fri Aug 17 2012 Minkyu Kang <mk7.kang@samasung.com> 0.1.37
+- FIX :
+ - button: fix alignment
+ - listview: adjust the main text width
+ - virtualgrid: refactoring
+- Spec changes:
+ - transition: support JQM 1.1.0 transitions
+ - scrollview: support the outer scroll
+ - notification: remove interval feature
+
+* Tue Aug 14 2012 Youmin Ha <youmin.ha@samasung.com> 0.1.36
+- FIX :
+ - checkboxRadio: Add left/right padding
+ - button: custom button & icon position
+ - virtuallist: remove 'recreate' test
+- Spec changes:
+ - header/footer: enable/disable support
+
+* Fri Aug 10 2012 Minkyu Kang <mk7.kang@samsung.com> 0.1.35
+- FIX :
+ - expandablelist: modify show animation
+ - virtualgrid: Redesign programming interface
+ - popupwindow: code clean and fixed issues
+ - pagelayout: fix content height
+ - license file update
+ - virtuallist: Change programming interface
+ - datetimepicker: getting days correctly
+ - searchbar: set to hidden when cancel button is hide
+ - White theme title font tuning
+- Spec changes:
+ - default theme tizen-gray to tizen-white
+ - set default page transition to none
+
+* Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.34
+- FIX :
+ - Back Button : enlarge backbutton click size for white theme
+- Feature :
+ - Expandable List : Add refresh api
+* Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.33
+- FIX :
+ - click event touch threshold tuning
+
+* Mon Aug 02 2012 Jinhyuk Jun <jinhyuk.jun@samsung.com> 0.1.32
+- FIX :
+ - Add back button highlight effect for white theme
+
+* Mon Aug 01 2012 Jinhyuk Jun <jinhyuk.jun@samsnug.com> 0.1.31
+- FIX :
+ - IME checkroutine update, improve relayout on resize event
+ - Add highlight effect for radio button list
+ - Scrollview : fix condition of updatelayout event
+- Feature : progressing : add show/hide api
+
+* Mon Jul 27 2012 Koeun Choi <koeun.choi@samsung.com> 0.1.30
+- FIX : virtuallist, virtualgrid: Clean up temporary jquery.template object to clear cache
+ add default theme option on buttonMarkup for tizen theme
+ [searchbar] first fix : focus/blur fixed
+ back button does not work when long press
+ scrollview: don't auto scrolling if resizing area is too large
+- Feature : notification : add api to set the icon at tickernoti
+ demo : update the list sample demo
+ Support tizen default theme
+
+* Mon Jul 23 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.29
+- Improvements & Bugfixes
+ - HOTFIX: Revert template function with jquery.template
+
+* Thu Jul 19 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.28
+- Improvements & Bugfixes
+ - Fix #WEB-1028: memory leak on virtuallist/virtualgrid
+- Spec changes
+ - $.tizen.loadTheme() function accepts theme name as arguement
+ - Scrollview supports 'updatelayout' callback
+
+* Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.27
+- Improvements & Bugfixes
+ - Revert 'preventing long-press popup' patch, to fix backbutton to work in SocialMagazine
+* Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.26
+- Improvements & Bugfixes
+ - Add tizen-white theme package, to make rpm build to be finished
-%package -n libweb-ui-fw
+* Tue Jul 17 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.25
+- Improvements & Bugfixes
+ - Set 'slide' as default page transition effect, by JQM patch
-%package -n libweb-ui-fw-theme-tizen-gray
+* Fri Jul 13 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.24
+- Improvements & Bugfixes
+ - Fix IME show/hide algorithm
+ - Fix error on virtualgrid: link _set_scrollbar_size() function to the one in virtuallist
-%package -n libweb-ui-fw-dev
+* Wed Jul 11 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.23
+- Improvements & Bugfixes
+ - Fix notification position
+ - Fix unit tests
-%package -n libweb-ui-fw-demo-tizen-gray
+ Fri Jul 6 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.22
+- Spec changes
+ - JQM 1.1 upgrade
+- Improvements & Bugfixes
+ - Transform3D support on scrollview
+ - Page layout supports IME control
+ - Mapview supports pinch zoom on JQM 1.1
+ - Fix wrong character on button in minified version
+ - Virtualgrid supports scrollbar
+ - Lots of bugfixes
+* Fri Jun 22 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.20
+- Spec changes
+ - Support 'latest' version (by symlink) for tizen-web-ui-fw.js path.
+ - imageslider : supports 'resize' event.
+ - listview : listview has 1px padding-bottom.
+ - loader : Change global namespace, from S to $.tizen.
+ - loader : Move loadCustomGlobalizeCulture() into $.tizen.util namespace.
+- Improvements & Bugfixes
+ - Scrollview : supports 'translate3d', instead of 'translate'.
+ - notification : reset timer when 'show' or 'refresh' event.
+ - JQM patch : Fix vclick event triggered twice.
+- Etc.
+ - Add & fix unit tests.
+* Thu Jun 14 2012 Youmin Ha <youmin.ha@samsung.com> 0.1.19
+- Spec changes
+ - mapview : new widget.
+ - notification : add .refresh() API.
+ - pagecontrol : add .value([val]) API, and change an attribute name 'data-initVal' to 'data-value'.
+- Improvements & Bugfixes
+ - Support minified CSS.
+ - loader : Fix & refactor 'loading globalize culture file' routine.
+ - JQM Patch : Calculate min-height of window in javascript code, and remove predefined min-height value from CSS.
+ - Many more bugfixes.
+- Etc.
+ - Add many unit tests.
+ - Fix test coverage instrumentation tool to work with current source code.