summaryrefslogtreecommitdiff
path: root/src_mobile/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src_mobile/CMakeLists.txt')
-rw-r--r--src_mobile/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/src_mobile/CMakeLists.txt b/src_mobile/CMakeLists.txt
new file mode 100644
index 0000000..0a978b0
--- /dev/null
+++ b/src_mobile/CMakeLists.txt
@@ -0,0 +1,31 @@
+# Copyright (c) 2011 Samsung Electronics Co., Ltd All Rights Reserved
+#
+# Licensed under the Flora License, Version 1.1 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://floralicense.org/license/
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+# @author Yunchan Cho (yunchan.cho@samsung.com)
+
+SET(TARGET_API web-provider-api)
+SET(TARGET_CORE web-provider-core)
+SET(TARGET_DAEMON web-provider)
+SET(TARGET_PLUGIN web-provider-plugin)
+
+INCLUDE_DIRECTORIES(
+ ${CMAKE_CURRENT_SOURCE_DIR}/API
+ ${CMAKE_CURRENT_SOURCE_DIR}/Core
+ ${CMAKE_CURRENT_SOURCE_DIR}/Plugin
+)
+
+ADD_SUBDIRECTORY(API)
+ADD_SUBDIRECTORY(Core)
+ADD_SUBDIRECTORY(Daemon)
+ADD_SUBDIRECTORY(Plugin)