summaryrefslogtreecommitdiff
path: root/sessreg/Makefile.am
diff options
context:
space:
mode:
authorHyungKyu Song <hk76.song@samsung.com>2013-02-16 00:20:28 +0900
committerHyungKyu Song <hk76.song@samsung.com>2013-02-16 00:20:28 +0900
commit9303391b39569d5c23cc65925cfdf1686acd70ec (patch)
tree7bca7d987434a569b02bf4d555685182e3ac568e /sessreg/Makefile.am
parentcf0763d9c1a7b58d98d3b2a07c69eb2f3ab734fc (diff)
downloadx11-xserver-utils-tizen_2.0.tar.gz
x11-xserver-utils-tizen_2.0.tar.bz2
x11-xserver-utils-tizen_2.0.zip
Diffstat (limited to 'sessreg/Makefile.am')
-rw-r--r--sessreg/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/sessreg/Makefile.am b/sessreg/Makefile.am
new file mode 100644
index 0000000..cddffd0
--- /dev/null
+++ b/sessreg/Makefile.am
@@ -0,0 +1,48 @@
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+SUBDIRS = man
+bin_PROGRAMS = sessreg
+
+AM_CFLAGS = $(CWARNFLAGS) $(SESSREG_CFLAGS)
+
+sessreg_SOURCES = \
+ sessreg.h \
+ sessreg.c
+
+if LINT
+ALL_LINT_FLAGS=$(LINT_FLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+ $(AM_CPPFLAGS) $(CPPFLAGS)
+
+lint:
+ $(LINT) $(ALL_LINT_FLAGS) $(sessreg_SOURCES)
+endif LINT
+
+MAINTAINERCLEANFILES = ChangeLog INSTALL
+
+.PHONY: ChangeLog INSTALL
+
+INSTALL:
+ $(INSTALL_CMD)
+
+ChangeLog:
+ $(CHANGELOG_CMD)
+
+dist-hook: ChangeLog INSTALL