summaryrefslogtreecommitdiff
path: root/packaging/libXres.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/libXres.spec')
-rw-r--r--packaging/libXres.spec65
1 files changed, 65 insertions, 0 deletions
diff --git a/packaging/libXres.spec b/packaging/libXres.spec
new file mode 100644
index 0000000..715a172
--- /dev/null
+++ b/packaging/libXres.spec
@@ -0,0 +1,65 @@
+Summary: X-Resource extension client library
+Name: libXres
+Version: 1.0.6
+Release: 1
+License: MIT
+Group: System Environment/Libraries
+URL: http://www.x.org
+
+Source0: %{name}-%{version}.tar.gz
+
+BuildRequires: pkgconfig(xext)
+BuildRequires: pkgconfig(resourceproto)
+BuildRequires: pkgconfig(xorg-macros)
+BuildRequires: pkgconfig(xproto)
+
+%description
+X-Resource is an extension that allows a client to query
+the X server about its usage of various resources.
+
+%package devel
+Summary: Development files for %{name}
+Group: Development/Libraries
+Requires: %{name} = %{version}-%{release}
+Provides: libxres-devel
+
+%description devel
+X.Org X11 libXres development package
+
+%prep
+%setup -q
+
+%build
+%reconfigure --disable-static \
+ LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed"
+make %{?jobs:-j%jobs}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+make install DESTDIR=$RPM_BUILD_ROOT
+
+# We intentionally don't ship *.la files
+rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
+
+%remove_docs
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
+%files
+%defattr(-,root,root,-)
+%doc AUTHORS COPYING ChangeLog
+%{_libdir}/libXRes.so.1
+%{_libdir}/libXRes.so.1.0.0
+
+%files devel
+%defattr(-,root,root,-)
+%{_includedir}/X11/extensions/XRes.h
+%{_libdir}/libXRes.so
+%{_libdir}/pkgconfig/xres.pc
+#%dir %{_mandir}/man3x
+#%{_mandir}/man3/*.3*