summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
new file mode 100644
index 0000000..5efe2c1
--- /dev/null
+++ b/tools/Makefile.am
@@ -0,0 +1,39 @@
+# Copyright (C) 1998, 1999, 2000, 2001, 2003,
+# 2004 Free Software Foundation, Inc.
+#
+# This file is part of GnuPG.
+#
+# GnuPG is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# GnuPG is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA
+
+## Process this file with automake to produce Makefile.in
+
+EXTRA_DIST = lspgpot ring-a-party mail-signed-keys convert-from-106
+INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/intl
+needed_libs = ../cipher/libcipher.a ../mpi/libmpi.a ../util/libutil.a
+other_libs = $(LIBICONV) $(LIBINTL) $(CAPLIBS)
+
+bin_PROGRAMS = gpgsplit
+noinst_PROGRAMS = mpicalc bftest clean-sat mk-tdata shmtest make-dns-cert
+
+if HAVE_USTAR
+bin_SCRIPTS = gpg-zip
+endif
+
+gpgsplit_LDADD = $(needed_libs) $(other_libs) @ZLIBS@
+mpicalc_LDADD = $(needed_libs) $(other_libs) @W32LIBS@
+bftest_LDADD = $(needed_libs) $(other_libs) @W32LIBS@ @DLLIBS@ @NETLIBS@ @LIBREADLINE@
+shmtest_LDADD = $(needed_libs) $(other_libs) @LIBREADLINE@
+
+gpgsplit mpicalc bftest shmtest: $(needed_libs)