summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorKibum Kim <kb0929.kim@samsung.com>2012-02-27 21:15:49 +0900
committerKibum Kim <kb0929.kim@samsung.com>2012-02-27 21:15:49 +0900
commit2d52d6fc067d33b5138345b24140fa49a4905639 (patch)
tree05a5bb604754e5bcfe5390bcd896116a13893450 /debian
downloadca-certificates-2d52d6fc067d33b5138345b24140fa49a4905639.tar.gz
ca-certificates-2d52d6fc067d33b5138345b24140fa49a4905639.tar.bz2
ca-certificates-2d52d6fc067d33b5138345b24140fa49a4905639.zip
tizen beta release
Diffstat (limited to 'debian')
-rw-r--r--debian/README6
-rw-r--r--debian/ca-certificates.install1
-rw-r--r--debian/changelog16
-rw-r--r--debian/compat1
-rw-r--r--debian/control12
-rw-r--r--debian/dirs2
-rw-r--r--debian/docs0
-rwxr-xr-xdebian/rules91
8 files changed, 129 insertions, 0 deletions
diff --git a/debian/README b/debian/README
new file mode 100644
index 0000000..eea81a5
--- /dev/null
+++ b/debian/README
@@ -0,0 +1,6 @@
+The Debian Package ca-certificates
+----------------------------
+
+Comments regarding the Package
+
+ -- root <kd0228.kim@samsung.com> Tue, 02 Nov 2010 14:30:36 +0900
diff --git a/debian/ca-certificates.install b/debian/ca-certificates.install
new file mode 100644
index 0000000..f975cf0
--- /dev/null
+++ b/debian/ca-certificates.install
@@ -0,0 +1 @@
+/opt/etc/ssl/certs/*
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..5b3cf5b
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,16 @@
+ca-certificates (0.0.1-6) unstable; urgency=low
+
+ * 11/12/21
+ * - remove unnecessary file
+ * Git: pkgs/c/ca-certificates
+ * Tag: ca-certificates_0.0.1-6
+
+ -- Kidong Kim <kd0228.kim@samsung.com> Wed, 21 Dec 2011 09:50:22 +0900
+
+ca-certificates (0.0.1-5) unstable; urgency=low
+
+ * remove COPYING and AUTHORS
+ * Git: pkgs/c/ca-certificates
+ * Tag: ca-certificates_0.0.1-5
+
+ -- Kidong Kim <kd0228.kim@samsung.com> Sat, 16 Jul 2011 11:18:01 +0900
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..73a968e
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,12 @@
+Source: ca-certificates
+Priority: extra
+Maintainer: Kidong Kim <kd0228.kim@samsung.com>
+Build-Depends: debhelper (>= 5)
+Standards-Version: 3.7.2
+Section: libs
+
+Package: ca-certificates
+Section: libs
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: install basic certificates which be used applications
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..ca882bb
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+usr/bin
+usr/sbin
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/debian/docs
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..30d800a
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,91 @@
+#!/usr/bin/make -f
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+PREFIX ?= /usr
+DATADIR ?= /opt
+CERTDIR ?= /opt/etc/ssl/
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+ touch configure-stamp
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+
+ for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
+ cat $$f > $${f%.in}; \
+ sed -i -e "s#@PREFIX@#$(PREFIX)#g" $${f%.in}; \
+ sed -i -e "s#@DATADIR@#$(DATADIR)#g" $${f%.in}; \
+ done
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ -$(MAKE) clean
+
+# for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
+# rm -f $${f%.in}; \
+# done
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ mkdir -p $(CURDIR)/debian/tmp/$(CERTDIR)
+ cp -rf $(CURDIR)/certs debian/tmp/$(CERTDIR)
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --sourcedir=debian/tmp
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_python
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+# dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure