summaryrefslogtreecommitdiff
path: root/server/plugin/wav/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'server/plugin/wav/Makefile.am')
-rw-r--r--server/plugin/wav/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/server/plugin/wav/Makefile.am b/server/plugin/wav/Makefile.am
new file mode 100644
index 0000000..b2a7110
--- /dev/null
+++ b/server/plugin/wav/Makefile.am
@@ -0,0 +1,18 @@
+lib_LTLIBRARIES = libsoundpluginwave.la
+
+libsoundpluginwave_la_SOURCES = mm_sound_plugin_codec_wave.c
+
+libsoundpluginwave_la_CFLAGS = \
+ $(MMCOMMON_CFLAGS) \
+ -I$(srcdir)/../../../include \
+ -I$(srcdir)/../../include \
+ $(MMLOGSVR_CFLAGS) -DMMF_LOG_OWNER=0x002 -DMMF_DEBUG_PREFIX=\"MMF-SOUND\"
+
+libsoundpluginwave_la_LIBADD = $(MMCOMMON_LIBS) \
+ $(MMLOGSVR_LIBS) \
+ $(srcdir)/../../../common/libmmfsoundcommon.la
+
+install-exec-hook:
+ mkdir -p $(DESTDIR)$(libdir)/soundplugins
+ ln -sf /usr/lib/libsoundpluginwave.so $(DESTDIR)$(libdir)/soundplugins/libsoundpluginwave.so
+