summaryrefslogtreecommitdiff
path: root/sys/oss/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sys/oss/Makefile.am')
-rw-r--r--sys/oss/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys/oss/Makefile.am b/sys/oss/Makefile.am
new file mode 100644
index 0000000..c42dfea
--- /dev/null
+++ b/sys/oss/Makefile.am
@@ -0,0 +1,28 @@
+plugin_LTLIBRARIES = libgstossaudio.la
+
+libgstossaudio_la_SOURCES = gstossaudio.c \
+ gstosshelper.c \
+ gstossmixer.c \
+ gstossmixerelement.c \
+ gstossmixertrack.c \
+ gstosssink.c \
+ gstosssrc.c
+
+libgstossaudio_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CFLAGS)
+libgstossaudio_la_LIBADD = \
+ $(GST_PLUGINS_BASE_LIBS) \
+ -lgstinterfaces-$(GST_MAJORMINOR) \
+ -lgstaudio-$(GST_MAJORMINOR) \
+ $(GST_BASE_LIBS) \
+ $(GST_LIBS)
+libgstossaudio_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstossaudio_la_LIBTOOLFLAGS = --tag=disable-static
+
+noinst_HEADERS = common.h \
+ gstosssink.h \
+ gstosssrc.h \
+ gstosshelper.h \
+ gstossdmabuffer.h \
+ gstossmixer.h \
+ gstossmixerelement.h \
+ gstossmixertrack.h