summaryrefslogtreecommitdiff
path: root/sys/directsound/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sys/directsound/Makefile.am')
-rw-r--r--sys/directsound/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/sys/directsound/Makefile.am b/sys/directsound/Makefile.am
new file mode 100644
index 0000000..8227905
--- /dev/null
+++ b/sys/directsound/Makefile.am
@@ -0,0 +1,18 @@
+plugin_LTLIBRARIES = libgstdirectsoundsink.la
+
+libgstdirectsoundsink_la_SOURCES = gstdirectsoundsink.c gstdirectsoundplugin.c
+libgstdirectsoundsink_la_CFLAGS = \
+ $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_BASE_CFLAGS) \
+ $(GST_CFLAGS) \
+ $(DIRECTSOUND_CFLAGS)
+libgstdirectsoundsink_la_LIBADD = \
+ $(GST_PLUGINS_BASE_LIBS) \
+ -lgstaudio-$(GST_MAJORMINOR) -lgstinterfaces-$(GST_MAJORMINOR) \
+ $(GST_BASE_LIBS) \
+ $(GST_LIBS) \
+ $(DIRECTSOUND_LIBS)
+libgstdirectsoundsink_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) $(DIRECTSOUND_LDFLAGS)
+libgstdirectsoundsink_la_LIBTOOLFLAGS = --tag=disable-static
+
+noinst_HEADERS = gstdirectsoundsink.h