summaryrefslogtreecommitdiff
path: root/gst/multifile/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/multifile/Makefile.am')
-rw-r--r--gst/multifile/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/gst/multifile/Makefile.am b/gst/multifile/Makefile.am
index 52e33bc..3c9e316 100644
--- a/gst/multifile/Makefile.am
+++ b/gst/multifile/Makefile.am
@@ -1,13 +1,18 @@
plugin_LTLIBRARIES = libgstmultifile.la
-libgstmultifile_la_SOURCES = gstmultifilesink.c gstmultifilesrc.c gstmultifile.c
-libgstmultifile_la_CFLAGS = $(GST_BASE_CFLAGS) $(GST_CFLAGS)
-libgstmultifile_la_LIBADD = $(GST_BASE_LIBS) $(GST_LIBS)
+libgstmultifile_la_SOURCES = \
+ gstmultifilesink.c \
+ gstmultifilesrc.c \
+ gstmultifile.c \
+ gstsplitfilesrc.c \
+ patternspec.c
+libgstmultifile_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(GIO_CFLAGS)
+libgstmultifile_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) -lgstvideo-@GST_MAJORMINOR@ $(GST_BASE_LIBS) $(GST_LIBS) $(GIO_LIBS)
libgstmultifile_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstmultifile_la_LIBTOOLFLAGS = --tag=disable-static
-noinst_HEADERS = gstmultifilesrc.h gstmultifilesink.h
+noinst_HEADERS = gstmultifilesrc.h gstmultifilesink.h gstsplitfilesrc.h patternspec.h
Android.mk: Makefile.am $(BUILT_SOURCES)