summaryrefslogtreecommitdiff
path: root/ext/gconf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/gconf/Makefile.am')
-rw-r--r--ext/gconf/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/ext/gconf/Makefile.am b/ext/gconf/Makefile.am
new file mode 100644
index 0000000..0f1cffb
--- /dev/null
+++ b/ext/gconf/Makefile.am
@@ -0,0 +1,27 @@
+plugin_LTLIBRARIES = libgstgconfelements.la
+
+libgstgconfelements_la_SOURCES = \
+ gstgconfaudiosink.c \
+ gstgconfaudiosrc.c \
+ gstgconfelements.c \
+ gstgconfvideosink.c \
+ gstgconfvideosrc.c \
+ gstswitchsink.c \
+ gstswitchsrc.c \
+ gstgconf.c
+
+DIR_CFLAGS = -DGST_GCONF_DIR=\"/system/gstreamer/@GST_MAJORMINOR@\"
+libgstgconfelements_la_CFLAGS = $(GST_CFLAGS) $(GCONF_CFLAGS) $(DIR_CFLAGS)
+libgstgconfelements_la_LIBADD = $(GST_LIBS) $(GCONF_LIBS)
+libgstgconfelements_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstgconfelements_la_LIBTOOLFLAGS = --tag=disable-static
+
+noinst_HEADERS = \
+ gstgconfaudiosink.h \
+ gstgconfaudiosrc.h \
+ gstgconfelements.h \
+ gstgconfvideosink.h \
+ gstgconfvideosrc.h \
+ gstswitchsink.h \
+ gstswitchsrc.h \
+ gstgconf.h