summaryrefslogtreecommitdiff
path: root/ext/esd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/esd/Makefile.am')
-rw-r--r--ext/esd/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/ext/esd/Makefile.am b/ext/esd/Makefile.am
new file mode 100644
index 0000000..a7a1464
--- /dev/null
+++ b/ext/esd/Makefile.am
@@ -0,0 +1,14 @@
+plugin_LTLIBRARIES = libgstesd.la
+
+libgstesd_la_SOURCES = esdsink.c gstesd.c
+libgstesd_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(ESD_CFLAGS)
+libgstesd_la_LIBADD = \
+ $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_MAJORMINOR) \
+ $(GST_BASE_LIBS) \
+ $(GST_LIBS) \
+ $(ESD_LIBS)
+libgstesd_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstesd_la_LIBTOOLFLAGS = --tag=disable-static
+
+noinst_HEADERS = esdsink.h esdmon.h
+EXTRA_DIST =