summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKim Kibum <kb0929.kim@samsung.com>2012-04-29 17:01:25 +0900
committerKim Kibum <kb0929.kim@samsung.com>2012-04-29 17:01:25 +0900
commitb2e57232c0c834bb25e051530553b0490963abeb (patch)
tree8124862d0c76bec9068c7a822d15d4c33dd3739a /configure.ac
parent79a71ed0fa8c86a0ea7769c1dd0e4aec2e8a64fb (diff)
downloadlibslp-location-b2e57232c0c834bb25e051530553b0490963abeb.tar.gz
libslp-location-b2e57232c0c834bb25e051530553b0490963abeb.tar.bz2
libslp-location-b2e57232c0c834bb25e051530553b0490963abeb.zip
upload tizen1.0 source
Diffstat (limited to 'configure.ac')
-rwxr-xr-x[-rw-r--r--]configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f574b41..a646f28 100644..100755
--- a/configure.ac
+++ b/configure.ac
@@ -4,7 +4,7 @@ AC_INIT(Location, 0.1, [sena06.kim@samsung.com])
AC_CONFIG_AUX_DIR([build-aux])
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_HEADER([config.h])
-AC_CONFIG_SRCDIR([location/location.c])
+AC_CONFIG_SRCDIR([location])
AM_INIT_AUTOMAKE([1.10.2 foreign -Wall -Werror])
# Check programs for making executable
@@ -50,7 +50,7 @@ AC_COMPILE_IFELSE(
AC_MSG_RESULT($has_visibility)
# Check dependencies
-PKG_CHECK_MODULES(LOCATION, [glib-2.0 gobject-2.0 gmodule-2.0 vconf])
+PKG_CHECK_MODULES(LOCATION, [glib-2.0 gobject-2.0 dbus-glib-1 gmodule-2.0 vconf])
AC_SUBST(LOCATION_LIBS)
AC_SUBST(LOCATION_CFLAGS)
@@ -81,6 +81,9 @@ AC_CONFIG_FILES([
location.pc
Makefile
location/Makefile
+location/manager/Makefile
+location/map-service/Makefile
+location/module/Makefile
tests/Makefile
])