summaryrefslogtreecommitdiff
path: root/xps-plugin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xps-plugin/Makefile.am')
-rwxr-xr-xxps-plugin/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/xps-plugin/Makefile.am b/xps-plugin/Makefile.am
new file mode 100755
index 0000000..8f86db3
--- /dev/null
+++ b/xps-plugin/Makefile.am
@@ -0,0 +1,15 @@
+################# Build library ################
+lib_LTLIBRARIES = libSLP-xps-plugin-replay.la
+
+libSLP_xps_plugin_replay_la_SOURCES = \
+ $(srcdir)/src/geoclue_xps_plugin_replay.c
+
+libSLP_xps_plugin_replay_la_CFLAGS = -Wall -fPIC -fvisibility=hidden -DEXPORT_API="__attribute__((visibility(\"default\")))" \
+ -I$(srcdir)/include \
+ $(GEOCLUE_XPS_PLUGIN_CFLAGS) \
+ $(VCONF_CFLAGS) \
+ $(DLOG_CFLAGS)
+
+libSLP_xps_plugin_replay_la_LDFLAGS = -Wl,--hash-style=both -Wl,--as-needed \
+ $(VCONF_LIBS) \
+ $(DLOG_LIBS)