summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules128
1 files changed, 0 insertions, 128 deletions
diff --git a/debian/rules b/debian/rules
deleted file mode 100755
index 795f28a..0000000
--- a/debian/rules
+++ /dev/null
@@ -1,128 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-
-# Uncomment this to turn on verbose mode.
-export DH_VERBOSE=1
-
-
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-
-CFLAGS ?= -Wall -g
-LDFLAGS ?=
-PREFIX ?= /usr
-DESTDIR ?= $(CURDIR)/debian/tmp
-DATADIR ?= $(DESTDIR)/etc/gps-manager
-
-#CFLAGS += -O0
-#CXXFLAGS += -O0
-CFLAGS += -fvisibility=hidden -Wall -fPIC
-CXXFLAGS += -fvisibility=hidden -Wall -fPIC
-LDFLAGS += -Wl,--as-needed -Wl,--hash-style=both
-
-configure: configure-stamp
-configure-stamp:
- dh_testdir
- # Add here commands to configure the package.
- ./autogen.sh
- mkdir -p build
- cd build && CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" ../configure --prefix=$(PREFIX) --datadir=$(DATADIR)
-
- touch $@
-
-build: build-stamp
-build-stamp: configure-stamp
- dh_testdir
-
- # Add here commands to compile the package.
- mkdir -p build
- cd build && $(MAKE)
- #docbook-to-man debian/ncurses.sgml > ncurses.1
-
- for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
- cat $$f > $${f%.in}; \
- sed -i -e "s#@PREFIX@#$(PREFIX)#g" $${f%.in}; \
- sed -i -e "s#@DATADIR@#$(DATADIR)#g" $${f%.in}; \
- done
-
- touch $@
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp configure-stamp
-
- # Add here commands to clean up after the build process.
- mkdir -p build
- cd build
- -$(MAKE) clean
- -$(MAKE) distclean
- cd ..
-
- for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
- rm -f $${f%.in}; \
- done
-
- find $(CURDIR) -name "Makefile.in" -exec rm -f {} \;
-
- dh_clean
- rm -rf build
- rm -rf build-aux
- rm -rf m4
- rm -f aclocal.m4 config.h.in configure
-
-install: build
- dh_testdir
- dh_testroot
-# dh_clean -k
- dh_installdirs
-
- # Add here commands to install the package into debian/ncurses.
- mkdir -p build
- cd build && $(MAKE) DESTDIR=$(DESTDIR) install
-
- mkdir -p $(DATADIR)/replay
- cp -a nmea-log/*.log $(DATADIR)/replay
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs
- dh_installdocs
- dh_installexamples
- dh_install #--sourcedir=debian/tmp
-# dh_installmenu
-# dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installpam
-# dh_installmime
-# dh_python
-# dh_installinit
-# dh_installcron
-# dh_installinfo
- dh_installman
- dh_link
- dh_strip --dbg-package=libslp-lbs-plugin-replay-dbg
- dh_compress
- dh_fixperms
-# dh_perl
- dh_makeshlibs
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install