summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorKim Kibum <kb0929.kim@samsung.com>2012-04-29 16:58:25 +0900
committerKim Kibum <kb0929.kim@samsung.com>2012-04-29 16:58:25 +0900
commit24c06363581c4713b198e0c12d6c01ae380da000 (patch)
tree3a3dad49a59cf69162e500ad1227eb767af8bf33 /debian
parentac39af3d1aa435f63c81d2b0308c38272deae124 (diff)
downloadhaptic-24c06363581c4713b198e0c12d6c01ae380da000.tar.gz
haptic-24c06363581c4713b198e0c12d6c01ae380da000.tar.bz2
haptic-24c06363581c4713b198e0c12d6c01ae380da000.zip
upload tizen1.0 source
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules5
2 files changed, 5 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 006f3cd..747e935 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,7 @@ Build-Depends: debhelper (>= 5), dlog-dev, libdevman-dev, libdevman-haptic-dev,
Package: capi-system-haptic
Architecture: any
-Depends: ${shilbs:Depends}, ${misc:Depends}
+Depends: ${shlibs:Depends}, ${misc:Depends}
Description: A Haptic library in Tizen Native API
Package: capi-system-haptic-dev
diff --git a/debian/rules b/debian/rules
index 92090e4..aca248d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,8 @@
#!/usr/bin/make -f
+FULLVER ?= $(shell dpkg-parsechangelog | grep Version: | cut -d ' ' -f 2 | cut -d '-' -f 1)
+MAJORVER ?= $(shell echo $(FULLVER) | cut -d '.' -f 1)
+
CFLAGS = -Wall -g
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
@@ -13,7 +16,7 @@ CMAKE_BUILD_DIR ?= $(CURDIR)/cmake_build_tmp
configure: configure-stamp
configure-stamp:
dh_testdir
- mkdir -p $(CMAKE_BUILD_DIR) && cd $(CMAKE_BUILD_DIR) && cmake ..
+ mkdir -p $(CMAKE_BUILD_DIR) && cd $(CMAKE_BUILD_DIR) && cmake .. -DFULLVER=${FULLVER} -DMAJORVER=${MAJORVER}
touch configure-stamp