summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJunghyuk Park <junghyuk.park@samsung.com>2012-02-15 15:34:59 +0900
committerJunghyuk Park <junghyuk.park@samsung.com>2012-02-15 15:34:59 +0900
commite78d68941d605175c7f3b49876122bdddafe4785 (patch)
treea29e590eaf23629dd8be01ca58b01927803df176 /debian/rules
parent2bea24c26d9eb39419670e0bb6a3a7d55f2466bd (diff)
downloadefl-util-e78d68941d605175c7f3b49876122bdddafe4785.tar.gz
efl-util-e78d68941d605175c7f3b49876122bdddafe4785.tar.bz2
efl-util-e78d68941d605175c7f3b49876122bdddafe4785.zip
Added version numbering
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 6e2e3ec..3815f73 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,10 +10,13 @@ endif
CMAKE_ROOT_DIR ?= $(CURDIR)
CMAKE_BUILD_DIR ?= $(CURDIR)/cmake_build_tmp
+FULLVER ?= $(shell dpkg-parsechangelog | grep Version: | cut -d ' ' -f 2 | cut -d '-' -f 1)
+MAJORVER ?= $(shell echo $(FULLVER) | cut -d '.' -f 1)
+
configure: configure-stamp
configure-stamp:
dh_testdir
- mkdir -p $(CMAKE_BUILD_DIR) && cd $(CMAKE_BUILD_DIR) && cmake ..
+ mkdir -p $(CMAKE_BUILD_DIR) && cd $(CMAKE_BUILD_DIR) && cmake .. -DFULLVER=${FULLVER} -DMAJORVER=${MAJORVER}
touch configure-stamp