summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJunghyuk Park <junghyuk.park@samsung.com>2012-02-15 15:34:59 +0900
committerJunghyuk Park <junghyuk.park@samsung.com>2012-02-15 15:34:59 +0900
commite78d68941d605175c7f3b49876122bdddafe4785 (patch)
treea29e590eaf23629dd8be01ca58b01927803df176 /CMakeLists.txt
parent2bea24c26d9eb39419670e0bb6a3a7d55f2466bd (diff)
downloadefl-util-e78d68941d605175c7f3b49876122bdddafe4785.tar.gz
efl-util-e78d68941d605175c7f3b49876122bdddafe4785.tar.bz2
efl-util-e78d68941d605175c7f3b49876122bdddafe4785.zip
Added version numbering
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7ceac5a..a1cdd13 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -35,6 +35,13 @@ ADD_LIBRARY(${fw_name} SHARED ${SOURCES})
TARGET_LINK_LIBRARIES(${fw_name} ${${fw_name}_LDFLAGS})
+SET_TARGET_PROPERTIES(${fw_name}
+ PROPERTIES
+ VERSION ${FULLVER}
+ SOVERSION ${MAJORVER}
+ CLEAN_DIRECT_OUTPUT 1
+)
+
INSTALL(TARGETS ${fw_name} DESTINATION lib)
INSTALL(
DIRECTORY ${INC_DIR}/ DESTINATION include/ui