summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/README0
-rw-r--r--debian/capi-system-device-dev.install4
-rw-r--r--debian/capi-system-device-dev.postinst1
-rw-r--r--debian/capi-system-device.install1
-rw-r--r--debian/capi-system-device.postinst1
-rw-r--r--debian/changelog13
-rw-r--r--debian/compat1
-rw-r--r--debian/control22
-rwxr-xr-xdebian/rules65
9 files changed, 108 insertions, 0 deletions
diff --git a/debian/README b/debian/README
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/debian/README
diff --git a/debian/capi-system-device-dev.install b/debian/capi-system-device-dev.install
new file mode 100644
index 0000000..761a28b
--- /dev/null
+++ b/debian/capi-system-device-dev.install
@@ -0,0 +1,4 @@
+/usr/include/*
+/usr/include/*/*
+/usr/lib/pkgconfig/*.pc
+
diff --git a/debian/capi-system-device-dev.postinst b/debian/capi-system-device-dev.postinst
new file mode 100644
index 0000000..1a24852
--- /dev/null
+++ b/debian/capi-system-device-dev.postinst
@@ -0,0 +1 @@
+#!/bin/sh
diff --git a/debian/capi-system-device.install b/debian/capi-system-device.install
new file mode 100644
index 0000000..4a755a4
--- /dev/null
+++ b/debian/capi-system-device.install
@@ -0,0 +1 @@
+/usr/lib/lib*.so*
diff --git a/debian/capi-system-device.postinst b/debian/capi-system-device.postinst
new file mode 100644
index 0000000..1a24852
--- /dev/null
+++ b/debian/capi-system-device.postinst
@@ -0,0 +1 @@
+#!/bin/sh
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..753c8a7
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,13 @@
+capi-system-device (0.1.0-5) unstable; urgency=low
+
+ * update versioning
+ * Git: api/device
+ * Tag: capi-system-device_0.1.0-5
+
+ -- Pius Lee <pius.lee@samsung.com> Thu, 15 Dec 2011 13:46:58 +0900
+
+capi-system-device (0.0.1-1) unstable; urgency=low
+
+ * Initial release.
+
+ -- Pius Lee <pius.lee@samsung.com> Wed, 07 Dec 2011 12:39:36 +0900
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..c0f1535
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,22 @@
+
+Source: capi-system-device
+Section: libs
+Priority: extra
+Maintainer: pius lee <pius.lee@samsung.com>
+Build-Depends: debhelper (>= 5), dlog-dev, libdevman-dev, libglib2.0-dev, capi-base-common-dev, libvconf-dev
+
+Package: capi-system-device
+Architecture: any
+Depends: ${shilbs:Depends}, ${misc:Depends}
+Description: A Device library in Tizen Native API
+
+Package: capi-system-device-dev
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, capi-system-device (= ${Source-Version}), dlog-dev, libdevman-dev, capi-base-common-dev, libvconf-dev
+Description: A Device library in Tizen Native API (DEV)
+
+Package: capi-system-device-dbg
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, capi-system-device (= ${Source-Version})
+Description: A Device library in Tizen Native API (DBG)
+
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..30e9018
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,65 @@
+#!/usr/bin/make -f
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+CMAKE_ROOT_DIR ?= $(CURDIR)
+CMAKE_BUILD_DIR ?= $(CURDIR)/cmake_build_tmp
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ mkdir -p $(CMAKE_BUILD_DIR) && cd $(CMAKE_BUILD_DIR) && cmake ..
+ touch configure-stamp
+
+
+build: build-stamp
+build-stamp: configure-stamp
+ dh_testdir
+ cd $(CMAKE_BUILD_DIR) && $(MAKE)
+ touch $@
+
+clean:
+ cd $(CMAKE_ROOT_DIR)
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+ rm -f `find . -name *.pc`
+ rm -rf $(CMAKE_BUILD_DIR)
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ cd $(CMAKE_BUILD_DIR) && $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
+
+binary-indep: build install
+
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --sourcedir=debian/tmp
+ dh_installman
+ dh_link
+ dh_strip --dbg-package=capi-system-device-dbg
+ dh_fixperms
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure
+