summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorByungWoo Lee <bw1212.lee@samsung.com>2012-02-15 11:41:15 +0900
committerByungWoo Lee <bw1212.lee@samsung.com>2012-02-15 11:41:15 +0900
commit0ed1b013e7bb03e4ee448d62c0b1f69e05953963 (patch)
tree61918be4c638088ad234558a03d08ac4e9e8a085 /debian/rules
parent06f235fd19f4a7b7ca8116bd1efff4762865feff (diff)
downloadconnection-0ed1b013e7bb03e4ee448d62c0b1f69e05953963.tar.gz
connection-0ed1b013e7bb03e4ee448d62c0b1f69e05953963.tar.bz2
connection-0ed1b013e7bb03e4ee448d62c0b1f69e05953963.zip
Add versioning of library
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 06ff135..678a339 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,8 @@
#!/usr/bin/make -f
CFLAGS = -Wall -g
+FULLVER ?= $(shell dpkg-parsechangelog | grep Version: | cut -d ' ' -f 2 | cut -d '-' -f 1)
+MAJORVER ?= $(shell echo $(FULLVER) | cut -d '.' -f 1)
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
CFLAGS += -O0
@@ -13,7 +15,7 @@ CMAKE_BUILD_DIR ?= $(CURDIR)/cmake_build_tmp
configure: configure-stamp
configure-stamp:
dh_testdir
- mkdir -p $(CMAKE_BUILD_DIR) && cd $(CMAKE_BUILD_DIR) && cmake ..
+ mkdir -p $(CMAKE_BUILD_DIR) && cd $(CMAKE_BUILD_DIR) && cmake .. -DFULLVER=${FULLVER} -DMAJORVER=${MAJORVER}
touch configure-stamp