summaryrefslogtreecommitdiff
path: root/docs/Makefile.am
diff options
context:
space:
mode:
authorjk7744.park <jk7744.park@samsung.com>2015-10-26 15:41:21 +0900
committerjk7744.park <jk7744.park@samsung.com>2015-10-26 15:41:21 +0900
commita3377e1039b10375101aa7fd1e3d28a744edc854 (patch)
tree5e2950689deaf406a4c81f17fa55a57503dc4776 /docs/Makefile.am
parent4ffb1d0e64a5ed0c877abcbc0cd178f8185870a1 (diff)
downloadatk-a3377e1039b10375101aa7fd1e3d28a744edc854.tar.gz
atk-a3377e1039b10375101aa7fd1e3d28a744edc854.tar.bz2
atk-a3377e1039b10375101aa7fd1e3d28a744edc854.zip
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
new file mode 100644
index 0000000..5fd3fc1
--- /dev/null
+++ b/docs/Makefile.am
@@ -0,0 +1,42 @@
+## Process this file with automake to produce Makefile.in
+
+AUTOMAKE_OPTIONS = 1.6
+
+# The name of the module.
+DOC_MODULE=atk
+
+# The top-level SGML file.
+DOC_MAIN_SGML_FILE=atk-docs.sgml
+
+# Extra options to supply to gtkdoc-scan
+SCAN_OPTIONS=--deprecated-guards=G_DISABLE_DEPRECATED
+# The directory containing the source code (if it contains documentation).
+DOC_SOURCE_DIR=../atk
+
+# Used for dependencies
+HFILE_GLOB = $(top_srcdir)/atk/*.h
+CFILE_GLOB = $(top_srcdir)/atk/*.c
+
+# Header files to ignore when scanning
+IGNORE_HFILES = atkmarshal.h atkintl.h
+
+# CFLAGS and LDFLAGS for compiling scan program. Only needed
+# if $(DOC_MODULE).types is non-empty.
+AM_CPPFLAGS = \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ $(DEP_CFLAGS)
+
+GTKDOC_LIBS = $(top_builddir)/atk/libatk-$(ATK_API_VERSION).la \
+ $(DEP_LIBS)
+
+# gtkdoc-mkdb related varaibles
+MKDB_OPTIONS =--sgml-mode
+content_files = \
+ version.xml
+HTML_IMAGES =
+
+include $(top_srcdir)/gtk-doc.make
+
+# Other files to distribute
+EXTRA_DIST += version.xml.in