summaryrefslogtreecommitdiff
path: root/packaging/zeromq.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/zeromq.spec')
-rw-r--r--packaging/zeromq.spec156
1 files changed, 156 insertions, 0 deletions
diff --git a/packaging/zeromq.spec b/packaging/zeromq.spec
new file mode 100644
index 0000000..5416fee
--- /dev/null
+++ b/packaging/zeromq.spec
@@ -0,0 +1,156 @@
+Name: zeromq
+Version: 3.2.2
+Release: 1
+Summary: The ZeroMQ messaging library
+Group: Applications/Internet
+License: LGPLv3+
+URL: http://www.zeromq.org/
+Source: http://download.zeromq.org/%{name}-%{version}.tar.gz
+Prefix: %{_prefix}
+Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildRequires: gcc, make, gcc-c++, libstdc++-devel
+Requires: libstdc++
+
+BuildRequires: libuuid-devel
+Requires: libuuid
+
+# Build pgm only on supported archs
+%ifarch pentium3 pentium4 athlon i386 i486 i586 i686 x86_64
+BuildRequires: python, perl
+%endif
+
+%description
+The 0MQ lightweight messaging kernel is a library which extends the
+standard socket interfaces with features traditionally provided by
+specialised messaging middleware products. 0MQ sockets provide an
+abstraction of asynchronous message queues, multiple messaging
+patterns, message filtering (subscriptions), seamless access to
+multiple transport protocols and more.
+
+This package contains the ZeroMQ shared library.
+
+%package devel
+Summary: Development files and static library for the ZeroMQ library
+Group: Development/Libraries
+Requires: %{name} = %{version}-%{release}, pkgconfig
+
+%description devel
+The 0MQ lightweight messaging kernel is a library which extends the
+standard socket interfaces with features traditionally provided by
+specialised messaging middleware products. 0MQ sockets provide an
+abstraction of asynchronous message queues, multiple messaging
+patterns, message filtering (subscriptions), seamless access to
+multiple transport protocols and more.
+
+This package contains ZeroMQ related development libraries and header files.
+
+%prep
+%setup -q
+
+%build
+%configure
+
+%{__make} %{?_smp_mflags}
+
+%install
+[ "%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
+
+mkdir -p %{buildroot}/usr/share/license
+cp COPYING %{buildroot}/usr/share/license/%{name}
+cat COPYING.LESSER >> %{buildroot}/usr/share/license/%{name}
+
+# Install the package to build area
+#%{__make} check
+%makeinstall
+
+%post
+/sbin/ldconfig
+
+%postun
+/sbin/ldconfig
+
+%clean
+[ "%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
+
+%files
+%manifest zeromq.manifest
+%defattr(-,root,root,-)
+
+# docs in the main package
+%doc AUTHORS ChangeLog COPYING COPYING.LESSER NEWS README
+
+# libraries
+%{_libdir}/libzmq.so.3
+%{_libdir}/libzmq.so.3.0.0
+
+/usr/share/license/%{name}
+
+#%attr(0755,root,root) %{_bindir}/zmq_forwarder
+#%attr(0755,root,root) %{_bindir}/zmq_queue
+#%attr(0755,root,root) %{_bindir}/zmq_streamer
+
+#%{_mandir}/man7/zmq.7.gz
+#%{_mandir}/man1/zmq_forwarder.1.gz
+#%{_mandir}/man1/zmq_queue.1.gz
+#%{_mandir}/man1/zmq_streamer.1.gz
+
+%files devel
+%defattr(-,root,root,-)
+%{_includedir}/zmq.h
+%{_includedir}/zmq_utils.h
+
+%{_libdir}/libzmq.la
+%{_libdir}/libzmq.a
+%{_libdir}/pkgconfig/libzmq.pc
+%{_libdir}/libzmq.so
+
+%{_mandir}/man3/zmq_bind.3.gz
+%{_mandir}/man3/zmq_close.3.gz
+%{_mandir}/man3/zmq_connect.3.gz
+%{_mandir}/man3/zmq_errno.3.gz
+%{_mandir}/man3/zmq_getsockopt.3.gz
+%{_mandir}/man3/zmq_init.3.gz
+%{_mandir}/man3/zmq_msg_close.3.gz
+%{_mandir}/man3/zmq_msg_copy.3.gz
+%{_mandir}/man3/zmq_msg_data.3.gz
+%{_mandir}/man3/zmq_msg_init.3.gz
+%{_mandir}/man3/zmq_msg_init_data.3.gz
+%{_mandir}/man3/zmq_msg_init_size.3.gz
+%{_mandir}/man3/zmq_msg_move.3.gz
+%{_mandir}/man3/zmq_msg_size.3.gz
+%{_mandir}/man3/zmq_poll.3.gz
+%{_mandir}/man3/zmq_recv.3.gz
+%{_mandir}/man3/zmq_recvmsg.3.gz
+%{_mandir}/man3/zmq_send.3.gz
+%{_mandir}/man3/zmq_sendmsg.3.gz
+%{_mandir}/man3/zmq_setsockopt.3.gz
+%{_mandir}/man3/zmq_socket.3.gz
+%{_mandir}/man3/zmq_strerror.3.gz
+%{_mandir}/man3/zmq_term.3.gz
+%{_mandir}/man3/zmq_version.3.gz
+%{_mandir}/man3/zmq_ctx_destroy.3.gz
+%{_mandir}/man3/zmq_ctx_get.3.gz
+%{_mandir}/man3/zmq_ctx_new.3.gz
+%{_mandir}/man3/zmq_ctx_set.3.gz
+%{_mandir}/man3/zmq_disconnect.3.gz
+%{_mandir}/man3/zmq_msg_get.3.gz
+%{_mandir}/man3/zmq_msg_more.3.gz
+%{_mandir}/man3/zmq_msg_recv.3.gz
+%{_mandir}/man3/zmq_msg_send.3.gz
+%{_mandir}/man3/zmq_msg_set.3.gz
+%{_mandir}/man3/zmq_proxy.3.gz
+%{_mandir}/man3/zmq_socket_monitor.3.gz
+%{_mandir}/man3/zmq_unbind.3.gz
+%{_mandir}/man7/zmq_epgm.7.gz
+%{_mandir}/man7/zmq_inproc.7.gz
+%{_mandir}/man7/zmq_ipc.7.gz
+%{_mandir}/man7/zmq_pgm.7.gz
+%{_mandir}/man7/zmq_tcp.7.gz
+%{_mandir}/man7/zmq.7.gz
+
+%changelog
+* Fri Apr 8 2011 Mikko Koppanen <mikko@kuut.io> 3.0.0-1
+- Update dependencies and packaged files
+
+* Sat Apr 10 2010 Mikko Koppanen <mkoppanen@php.net> 2.0.7-1
+- Initial packaging