summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorKibum Kim <kb0929.kim@samsung.com>2012-01-07 00:47:33 +0900
committerKibum Kim <kb0929.kim@samsung.com>2012-01-07 00:47:33 +0900
commit8df0096515fc2575560e13982f9edf76bf39555e (patch)
tree0d683bc1583f241ae5675f5fbdccb7260212b35b /debian
parentdbc5ef4889caa206f4d47d83345357780ceef73e (diff)
downloadiptables-8df0096515fc2575560e13982f9edf76bf39555e.tar.gz
iptables-8df0096515fc2575560e13982f9edf76bf39555e.tar.bz2
iptables-8df0096515fc2575560e13982f9edf76bf39555e.zip
Git init
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog13
-rw-r--r--debian/compat1
-rw-r--r--debian/control32
-rw-r--r--debian/iptables-dev.install3
-rw-r--r--debian/iptables.install5
-rwxr-xr-xdebian/rules119
6 files changed, 173 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..a709a92
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,13 @@
+iptables (1.4.9.1-slp2+2) unstable; urgency=low
+
+ * Version is updated
+ * Git: pkgs/i/iptables
+ * Tag: iptables_1.4.9.1-slp2+2
+
+ -- Seungyoun Ju <sy39.ju@samsung.com> Thu, 22 Dec 2011 19:19:34 +0900
+
+iptables (1.4.9.1-slp2+1) unstable; urgency=low
+
+ * Initial version release
+
+ -- Seungyoun Ju <sy39.ju@samsung.com> Wed, 07 Dec 2011 13:03:19 +0900
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..63c7eb3
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,32 @@
+Source: iptables
+Section: net
+Priority: important
+Maintainer: Seungyoun Ju <sy39.ju@samsung.com>, Hocheol Seo <hocheol.seo@samsung.com>
+Build-Depends: debhelper (>= 5), autotools-dev
+Standards-Version: 3.7.2
+
+Package: iptables
+Architecture: any
+Priority: important
+Section: net
+Depends: ${shlibs:Depends}
+Description: administration tools for packet filtering and NAT
+ These are the user-space administration tools for the Linux
+ kernel's netfilter and iptables. netfilter and iptables provide
+ a framework for stateful and stateless packet filtering, network
+ and port address translation, and other IP packet manipulation.
+ The framework is the successor to ipchains.
+ netfilter and iptables are used in applications such as Internet
+ connection sharing, firewalls, IP accounting, transparent proxying,
+ advanced routing and traffic control.
+
+Package: iptables-dev
+XB-Public-Package: no
+Architecture: any
+Priority: optional
+Depends: ${shlibs:Depends}, ${misc:Depends}, iptables (= ${Source-Version})
+Section: devel
+Description: development files for iptable's libipq
+ Header files, static libs and documentation for libipq, iptables'
+ user-space packet queuing library.
+
diff --git a/debian/iptables-dev.install b/debian/iptables-dev.install
new file mode 100644
index 0000000..1af545f
--- /dev/null
+++ b/debian/iptables-dev.install
@@ -0,0 +1,3 @@
+usr/include/*
+usr/lib/*.la
+usr/lib/pkgconfig/*
diff --git a/debian/iptables.install b/debian/iptables.install
new file mode 100644
index 0000000..5245967
--- /dev/null
+++ b/debian/iptables.install
@@ -0,0 +1,5 @@
+usr/lib/*.so
+usr/lib/lib*.so.*
+usr/libexec/*
+usr/sbin/iptables*
+
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..d10ad57
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,119 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+LDFLAGS ?=
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+
+CFLAGS = -Wall -g
+LDFLAGS += -Wl,--as-needed
+
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+
+# shared library versions, option 1
+version=2.0.5
+major=2
+# option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
+#version=`ls src/.libs/lib*.so.* | \
+# awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
+#major=`ls src/.libs/lib*.so.* | \
+# awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
+
+config.status: configure
+ dh_testdir
+ # Add here commands to configure the package.
+ ./configure --prefix=/usr
+ #--mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
+#--host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE)
+
+build: build-stamp
+
+build-stamp: config.status
+ dh_testdir
+
+ # Add here commands to compile the package.
+ $(MAKE)
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+
+ # Add here commands to clean up after the build process.
+ -$(MAKE) distclean
+ifneq "$(wildcard /usr/share/misc/config.sub)" ""
+ cp -f /usr/share/misc/config.sub config.sub
+endif
+ifneq "$(wildcard /usr/share/misc/config.guess)" ""
+ cp -f /usr/share/misc/config.guess config.guess
+endif
+
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/tmp
+ $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --sourcedir=debian/tmp
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_python
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install