summaryrefslogtreecommitdiff
path: root/.pc/tizen.patch/providers/example/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '.pc/tizen.patch/providers/example/Makefile.am')
-rwxr-xr-x.pc/tizen.patch/providers/example/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/.pc/tizen.patch/providers/example/Makefile.am b/.pc/tizen.patch/providers/example/Makefile.am
new file mode 100755
index 0000000..bb052fc
--- /dev/null
+++ b/.pc/tizen.patch/providers/example/Makefile.am
@@ -0,0 +1,30 @@
+libexec_PROGRAMS = geoclue-example
+
+geoclue_example_CFLAGS = \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ $(GEOCLUE_CFLAGS)
+
+geoclue_example_LDADD = \
+ $(GEOCLUE_LIBS) \
+ $(top_builddir)/geoclue/libgeoclue.la
+
+geoclue_example_SOURCES = \
+ geoclue-example.c
+
+providersdir = $(datadir)/geoclue-providers
+providers_DATA = geoclue-example.provider
+
+servicedir = $(DBUS_SERVICES_DIR)
+service_in_files = org.freedesktop.Geoclue.Providers.Example.service.in
+service_DATA = $(service_in_files:.service.in=.service)
+
+$(service_DATA): $(service_in_files) Makefile
+ $(AM_V_GEN) sed -e "s|\@libexecdir\@|$(libexecdir)|" $< > $@
+
+EXTRA_DIST = \
+ $(service_in_files) \
+ $(providers_DATA)
+
+DISTCLEANFILES = \
+ $(service_DATA)