summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/changelog7
-rwxr-xr-xdebian/compat1
-rwxr-xr-xdebian/control21
-rwxr-xr-xdebian/libug-setting-gallery-efl-dbg.install.in1
-rwxr-xr-xdebian/libug-setting-gallery-efl.install.in7
-rwxr-xr-xdebian/libug-setting-gallery-efl.postinst27
-rwxr-xr-xdebian/rules126
7 files changed, 0 insertions, 190 deletions
diff --git a/debian/changelog b/debian/changelog
deleted file mode 100755
index b5077ee..0000000
--- a/debian/changelog
+++ /dev/null
@@ -1,7 +0,0 @@
-ug-setting-gallery-efl (1.0.17) unstable; urgency=low
-
- * Initial version
- * Git: pkgs/u/ug-setting-gallery-efl.git
- * Tag: ug-setting-gallery-efl_1.0.17
-
- -- Jonghyuk Lee <jhyuk47.lee@samsung.com> Wed, 07 Dec 2011 15:30:52 +0900
diff --git a/debian/compat b/debian/compat
deleted file mode 100755
index b8626c4..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-4
diff --git a/debian/control b/debian/control
deleted file mode 100755
index 992b6aa..0000000
--- a/debian/control
+++ /dev/null
@@ -1,21 +0,0 @@
-Source: ug-setting-gallery-efl
-Section: libs
-Priority: extra
-maintainer: Sangjin Han <sjhan.haN@samsung.com>, Li Suxia <suxia.li@samsung.com>, Tang Feng <feng.tang@samsung.com>, Hyunwoo Kim <hw4444.kim@samsung.com>, Jisung Ahn <jcastle.ahn@samsung.com>, Jiansong Jin <jiansong.jin@samsung.com>, Jonghyuk Lee <jhyuk47.lee@samsung.com>, Chaolong Lin <chaolong.lin@samsung.com>, Yongjun Zhao <yj123.zhao@samsung.com>, Hongying Liu <ava.liu@samsung.com>, JongDong Lee <jongdong.lee@samsung.com>
-Build-Depends: debhelper (>= 5), libelm-dev, libbundle-dev, libui-gadget-dev, libslp-setting-dev, libslp-setting-keys-dev, dlog-dev
-Standards-Version: 0.0.1
-
-Package: libug-setting-gallery-efl
-Section: libs
-Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}
-Description: UI gadget for setting gallery
-Version: 0.0.1
-
-Package: libug-setting-gallery-efl-dbg
-Section: debug
-Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, libug-setting-gallery-efl(= ${Source-Version})
-Description: UI gadget for setting gallery (unstripped)
-Version: 0.0.1
-
diff --git a/debian/libug-setting-gallery-efl-dbg.install.in b/debian/libug-setting-gallery-efl-dbg.install.in
deleted file mode 100755
index bf766f0..0000000
--- a/debian/libug-setting-gallery-efl-dbg.install.in
+++ /dev/null
@@ -1 +0,0 @@
-@PREFIX@/lib/*.so*
diff --git a/debian/libug-setting-gallery-efl.install.in b/debian/libug-setting-gallery-efl.install.in
deleted file mode 100755
index 3e59eab..0000000
--- a/debian/libug-setting-gallery-efl.install.in
+++ /dev/null
@@ -1,7 +0,0 @@
-#@PREFIX@/bin/*
-#@PREFIX@/lib/ug/*.so*
-#@PREFIX@/share/ug/icon/*.png
-#@PREFIX@/share/ug/edje/*.edj
-#@PREFIX@/share/locale/*
-/opt/ug/lib/*
-/opt/ug/res/*
diff --git a/debian/libug-setting-gallery-efl.postinst b/debian/libug-setting-gallery-efl.postinst
deleted file mode 100755
index cd68472..0000000
--- a/debian/libug-setting-gallery-efl.postinst
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/bin/sh
-
-#init keys
-export LD_LIBRARY_PATH=/usr/lib/ug:$LD_LIBRARY_PATH
-
-if [ ${USER} = "root" ]
-then
-
-/usr/bin/vconftool set -t double db/setting/gallery/interval_time 3.0 -g 6514
-/usr/bin/vconftool set -t string db/setting/gallery/ss_effect "Slide" -g 6514
-/usr/bin/vconftool set -t bool db/setting/gallery/repeat_state 0 -g 6514
-/usr/bin/vconftool set -t bool db/setting/gallery/shuffle_state 0 -g 6514
-/usr/bin/vconftool set -t bool db/setting/gallery/subtitle_state 0 -g 6514
-
-else
-
-/usr/bin/vconftool set -t double db/setting/gallery/interval_time 3.0
-/usr/bin/vconftool set -t string db/setting/gallery/ss_effect "Slide"
-/usr/bin/vconftool set -t bool db/setting/gallery/repeat_state 0
-/usr/bin/vconftool set -t bool db/setting/gallery/shuffle_state 0
-/usr/bin/vconftool set -t bool db/setting/gallery/subtitle_state 0
-
-fi
-
-#file permission
-
-
diff --git a/debian/rules b/debian/rules
deleted file mode 100755
index 64569c9..0000000
--- a/debian/rules
+++ /dev/null
@@ -1,126 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-#export VERBOSE=1
-
-CFLAGS += -Wall -g
-CXXFLAGS += -Wall -g
-LDFLAGS ?=
-PREFIX ?= /usr
-DATADIR ?= /opt
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
- CXXFLAGS += -O0
-else
- CFLAGS += -O2
- CXXFLAGS += -O2
-endif
-
-LDFLAGS += -Wl,--rpath=$(PREFIX)/lib -Wl,--as-needed
-
-configure: configure-stamp
-configure-stamp:
- dh_testdir
- # Add here commands to configure the package.
- CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" LDFLAGS="$(LDFLAGS)" cmake . -DCMAKE_INSTALL_PREFIX=$(PREFIX)
-
- touch configure-stamp
-
-build: build-stamp
-
-build-stamp: configure-stamp
- dh_testdir
-
- # Add here commands to compile the package.
- $(MAKE)
- #docbook-to-man debian/wavplayer.sgml > wavplayer.1
-
- for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
- cat $$f > $${f%.in}; \
- sed -i -e "s#@PREFIX@#$(PREFIX)#g" $${f%.in}; \
- sed -i -e "s#@DATADIR@#$(DATADIR)#g" $${f%.in}; \
- done
-
- touch $@
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp configure-stamp
-
- # Add here commands to clean up after the build process.
- -$(MAKE) clean
- rm -rf CMakeCache.txt
- rm -rf CMakeFiles
- rm -rf cmake_install.cmake
- rm -rf Makefile
- rm -rf install_manifest.txt
- rm -rf *.so
- rm -rf po/*.mo
- rm -rf po/CMakeCache.txt
- rm -rf po/CMakeFiles
- rm -rf po/cmake_install.cmake
- rm -rf po/Makefile
- rm -rf po/install_manifest.txt
-
- for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
- rm -f $${f%.in}; \
- done
-
- dh_clean
-
-install: build
- dh_testdir
- dh_prep
- dh_installdirs
-
- # Add here commands to install the package into debian/wavplayer.
- $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
-
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
-# dh_installchangelogs
-# dh_installdocs
-# dh_installexamples
- dh_install --sourcedir=debian/tmp
-# dh_installmenu
-# dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installpam
-# dh_installmime
-# dh_python
-# dh_installinit
-# dh_installcron
-# dh_installinfo
- dh_installman
- dh_link
- dh_strip --dbg-package=libug-setting-gallery-efl
- dh_compress
- dh_fixperms
-# dh_perl
- dh_makeshlibs
- dh_installdeb
-# dh_shlibdeps
- dh_shlibdeps -l /usr/lib/ug
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure