summaryrefslogtreecommitdiff
path: root/lib/list/CMakeLists.txt
diff options
context:
space:
mode:
authorSunggoo Kim <sung.goo.kim@samsung.com>2012-08-21 18:17:42 +0900
committerSunggoo Kim <sung.goo.kim@samsung.com>2012-08-21 18:17:42 +0900
commit41b2478dc578156bb904201f8f6e2d9d35c26f9f (patch)
tree88f4757f2e2bf498b67889f0901bf9f0fcb13057 /lib/list/CMakeLists.txt
parente9d80f84b140bb86fe9e7bc025ec1de25f6b1cad (diff)
downloadphone-contacts-41b2478dc578156bb904201f8f6e2d9d35c26f9f.tar.gz
phone-contacts-41b2478dc578156bb904201f8f6e2d9d35c26f9f.tar.bz2
phone-contacts-41b2478dc578156bb904201f8f6e2d9d35c26f9f.zip
migration
Diffstat (limited to 'lib/list/CMakeLists.txt')
-rwxr-xr-xlib/list/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/lib/list/CMakeLists.txt b/lib/list/CMakeLists.txt
new file mode 100755
index 0000000..b2e29d1
--- /dev/null
+++ b/lib/list/CMakeLists.txt
@@ -0,0 +1,18 @@
+LINK_DIRECTORIES(${CMAKE_BINARY_DIR})
+
+SET(TARGET ${CT_LIST})
+
+FILE(GLOB SRCS *.c)
+
+ADD_LIBRARY(${TARGET} SHARED ${SRCS})
+SET_TARGET_PROPERTIES(${TARGET} PROPERTIES SOVERSION ${VERSION_MAJOR})
+SET_TARGET_PROPERTIES(${TARGET} PROPERTIES VERSION ${VERSION})
+
+SET_TARGET_PROPERTIES(${TARGET} PROPERTIES COMPILE_FLAGS ${EXTRA_CFLAGS})
+TARGET_LINK_LIBRARIES(${TARGET} ${COMMON_LIB} ${ug_pkgs_LDFLAGS} ${CT_DETAILS})
+
+ADD_DEPENDENCIES(${TARGET} contacts_edj_build contacts_theme_build list_theme_edj_build)
+
+INSTALL(TARGETS ${TARGET} DESTINATION ${UGLIBDIR})
+
+INSTALL(FILES ${CMAKE_BINARY_DIR}/lib/list/contacts-list-efl.xml DESTINATION "/usr/share/packages")