summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorKim Kibum <kb0929.kim@samsung.com>2012-06-08 14:54:07 +0900
committerKim Kibum <kb0929.kim@samsung.com>2012-06-08 14:54:07 +0900
commit5f6271abd18e2d811315f56c48ecd927c9e9436c (patch)
tree8c85b9a44e77a3d9d095a92962c18882592f16a7 /debian
parent49f24a8d096e66cccb869a4da0ec38a069eae870 (diff)
downloadmessage-app-5f6271abd18e2d811315f56c48ecd927c9e9436c.tar.gz
message-app-5f6271abd18e2d811315f56c48ecd927c9e9436c.tar.bz2
message-app-5f6271abd18e2d811315f56c48ecd927c9e9436c.zip
apply FSL(Flora Software License)
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog7
-rwxr-xr-xdebian/compat1
-rwxr-xr-xdebian/control21
-rwxr-xr-xdebian/dirs2
-rwxr-xr-xdebian/docs2
-rwxr-xr-xdebian/org.tizen.message.install.in9
-rwxr-xr-xdebian/org.tizen.message.postinst.in8
-rwxr-xr-xdebian/rules125
8 files changed, 175 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..34115a9
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,7 @@
+message (0.8.2-20) unstable; urgency=low
+
+ * Git: slp/pkgs/m/message-app
+ * Tag: message_0.8.2-20
+
+ -- Jaeyun Jeong <jyjeong@samsung.com> Mon, 16 Apr 2012 19:26:38 +0900
+
diff --git a/debian/compat b/debian/compat
new file mode 100755
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100755
index 0000000..87d24d0
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,21 @@
+Source: message
+Section: devel
+Priority: optional
+Maintainer: Jaeyun Jeong <jyjeong@samsung.com>, Sangkoo Kim <sangkoo.kim@samsung.com>, Seunghwan Lee <sh.cat.lee@samsung.com>, SoonMin Jung <sm0415.jung@samsung.com>, Jae-Young Lee <jy4710.lee@samsung.com>
+Build-Depends: debhelper (>= 5), libglib2.0-dev, libelm-dev, libecore-dev, libeina-dev, libappcore-common-dev, libappcore-efl-dev, libslp-msg-service-dev, libslp-setting-dev, libslp-utilx-dev, dlog-dev, libui-gadget-dev, libcontacts-service-dev, libug-contacts-dev, libicu-dev, libappsvc-dev, libdevman-haptic-dev, libheynoti-dev, capi-appfw-application-dev
+Standards-Version: 3.7.2
+Homepage:
+
+Package: org.tizen.message
+Section: devel
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: message application
+Version: 0.1.0
+
+Package: org.tizen.message-dbg
+Section: debug
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: message application (unstripped)
+Version: 0.1.0
diff --git a/debian/dirs b/debian/dirs
new file mode 100755
index 0000000..ca882bb
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+usr/bin
+usr/sbin
diff --git a/debian/docs b/debian/docs
new file mode 100755
index 0000000..7a77580
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1,2 @@
+CMakeCache.txt
+CMakeLists.txt
diff --git a/debian/org.tizen.message.install.in b/debian/org.tizen.message.install.in
new file mode 100755
index 0000000..d939590
--- /dev/null
+++ b/debian/org.tizen.message.install.in
@@ -0,0 +1,9 @@
+@PREFIX@/bin/*
+@PREFIX@/res/locale/*
+@PREFIX@/res/icons/*
+@PREFIX@/res/images/*
+@PREFIX@/res/edje/*
+@PREFIX@/data
+@PREFIX@/lib/*
+/opt/share/applications/*
+/opt/ug/lib/*
diff --git a/debian/org.tizen.message.postinst.in b/debian/org.tizen.message.postinst.in
new file mode 100755
index 0000000..2b96d78
--- /dev/null
+++ b/debian/org.tizen.message.postinst.in
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+#if [ ${USER} = "root" ]
+if [ "`id -u`" = "0" ]
+then
+ #5000 is inhouse user id
+ chown -R 5000:5000 @DATADIR@
+fi
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..686d100
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,125 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+CFLAGS += -Wall -g
+LDFLAGS ?=
+PREFIX ?= /opt/apps/org.tizen.message
+RESDIR ?= /opt/apps/org.tizen.message/res
+DATADIR ?= /opt/apps/org.tizen.message/data
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+
+LDFLAGS += -Wl,--rpath=$(PREFIX)/lib -Wl,--as-needed
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+ CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" cmake . -DCMAKE_INSTALL_PREFIX=${PREFIX}
+
+ touch configure-stamp
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+ $(MAKE)
+
+ for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
+ cat $$f > $${f%.in}; \
+ sed -i -e "s#@PREFIX@#$(PREFIX)#g" $${f%.in}; \
+ sed -i -e "s#@RESDIR@#$(RESDIR)#g" $${f%.in}; \
+ sed -i -e "s#@DATADIR@#$(DATADIR)#g" $${f%.in}; \
+ done
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # Add here commands to clean up after the build process.
+ -$(MAKE) clean
+ rm -f CMakeCache.txt
+ rm -rf CMakeFiles main/CMakeFiles composer/CMakeFiles setting/CMakeFiles dialog/CMakeFiles common/CMakeFiles
+ rm -f cmake_install.cmake main/cmake_install.cmake composer/cmake_install.cmake setting/cmake_install.cmake dialog/cmake_install.cmake common/cmake_install.cmake
+ rm -f Makefile main/Makefile composer/Makefile setting/Makefile dialog/Makefile common/Makefile
+ rm -f install_manifest.txt main/install_manifest.txt composer/install_manifest.txt setting/install_manifest.txt dialog/install_manifest.txt common/install_manifest.txt
+ rm -f main/po/CMakeCache.txt
+ rm -rf main/po/CMakeFiles
+ rm -f main/po/cmake_install.cmake
+ rm -f main/po/Makefile
+# rm -f po/install_manifest.txt
+
+ rm -f *.so composer/*.so setting/*.so common/*.so
+ rm -f *.edj thread/theme/*.edj composer/data/composer_edc/*.edj bubble/theme/*.edj setting/theme/*.edj
+ rm -f main/*.desktop
+
+ for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
+ rm -f $${f%.in}; \
+ done
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/wavplayer.
+ $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+ dh_install --sourcedir=debian/tmp
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_python
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip --dbg-package=org.tizen.message-dbg
+ dh_compress
+ dh_fixperms
+# dh_perl
+ dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure