summaryrefslogtreecommitdiff
path: root/wearable/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'wearable/debian/rules')
-rwxr-xr-xwearable/debian/rules125
1 files changed, 0 insertions, 125 deletions
diff --git a/wearable/debian/rules b/wearable/debian/rules
deleted file mode 100755
index d92d709..0000000
--- a/wearable/debian/rules
+++ /dev/null
@@ -1,125 +0,0 @@
-#!/usr/bin/make -f
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-CFLAGS ?= -Wall -g
-LDFLAGS ?=
-PREFIX ?= /usr
-DATADIR ?= /opt
-PLUGIN_PREFIX ?= /usr
-
-CMAKE_BUILD_DIR ?= $(CURDIR)/cmake_build_tmp
-
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -O0
-else
- CFLAGS += -O2
-endif
-
-LDFLAGS += -Wl,--rpath=$(PREFIX)/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs
-
-configure: configure-stamp
-configure-stamp:
- dh_testdir
- # Add here commands to configure the package.
- mkdir -p $(CMAKE_BUILD_DIR) && \
- cd $(CMAKE_BUILD_DIR) && \
- CFLAGS="$(CFLAGS) -fpie" LDFLAGS="$(LDFLAGS) -pie" \
- cmake .. -DCMAKE_INSTALL_PREFIX=$(PREFIX) -DPLUGIN_INSTALL_PREFIX=$(PLUGIN_PREFIX)
-
- touch configure-stamp
-
-build: build-stamp
-
-build-stamp: configure-stamp
- dh_testdir
-
- # Add here commands to compile the package.
- cd $(CMAKE_BUILD_DIR) && $(MAKE)
-
- for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
- cat $$f > $${f%.in}; \
- sed -i -e "s#@PREFIX@#$(PREFIX)#g" $${f%.in}; \
- sed -i -e "s#@DATADIR@#$(DATADIR)#g" $${f%.in}; \
- sed -i -e "s#@PLUGIN_PREFIX@#$(PLUGIN_PREFIX)#g" $${f%.in}; \
- done
-
- touch $@
-
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp configure-stamp
-
- # Add here commands to clean up after the build process.
- -rm -rf $(CMAKE_BUILD_DIR)
- for f in `find $(CURDIR)/debian/ -name "*.in"`; do \
- rm -f $${f%.in}; \
- done
-
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- # Add here commands to install the package into debian/wavplayer.
- cd $(CMAKE_BUILD_DIR) && $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
-
-
-
- # Booting script
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs
- dh_installdocs
- dh_installexamples
- dh_install --sourcedir=debian/tmp
-
- # Install extra shell script
- mkdir -p $(CURDIR)/debian/bluetooth-firmware-bcm-c210/usr/etc/bluetooth/
- mkdir -p $(CURDIR)/debian/bluetooth-firmware-bcm-e4412/usr/etc/bluetooth/
-
- cp -a $(CURDIR)/debian/tmp/usr/etc/bluetooth/bt-dev-end.sh $(CURDIR)/debian/bluetooth-firmware-bcm-c210/usr/etc/bluetooth/bt-dev-end.sh
- cp -a $(CURDIR)/debian/tmp/usr/etc/bluetooth/bt-dev-start-c210.sh $(CURDIR)/debian/bluetooth-firmware-bcm-c210/usr/etc/bluetooth/bt-dev-start.sh
- cp -a $(CURDIR)/debian/tmp/usr/etc/bluetooth/bt-set-addr.sh $(CURDIR)/debian/bluetooth-firmware-bcm-c210/usr/etc/bluetooth/bt-set-addr.sh
-
- cp -a $(CURDIR)/debian/tmp/usr/etc/bluetooth/bt-dev-end.sh $(CURDIR)/debian/bluetooth-firmware-bcm-e4412/usr/etc/bluetooth/bt-dev-end.sh
- cp -a $(CURDIR)/debian/tmp/usr/etc/bluetooth/bt-dev-start-e4412.sh $(CURDIR)/debian/bluetooth-firmware-bcm-e4412/usr/etc/bluetooth/bt-dev-start.sh
- cp -a $(CURDIR)/debian/tmp/usr/etc/bluetooth/bt-set-addr.sh $(CURDIR)/debian/bluetooth-firmware-bcm-e4412/usr/etc/bluetooth/bt-set-addr.sh
-
-# dh_installmenu
-# dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installpam
-# dh_installmime
-# dh_python
-# dh_installinit
-# dh_installcron
-# dh_installinfo
- dh_installman
- dh_link
- dh_strip --dbg-package=bluetooth-firmware-bcm-c210-dbg --dbg-package=bluetooth-firmware-bcm-e4412-dbg
- dh_compress
- dh_fixperms
-# dh_perl
- dh_makeshlibs
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure