summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorbiao716.wang <biao716.wang@samsung.com>2020-11-12 16:05:41 +0900
committerbiao716.wang <biao716.wang@samsung.com>2020-11-13 14:10:03 +0900
commit28afff5592dec6a66cfad5688b2f7663f82ec480 (patch)
tree67c7ae1d369622a55f5a12e05dd2d92692c31ee3 /debian
parent3429128ee027def6c23ac678465447f445877cd6 (diff)
downloadpython-urlgrabber-28afff5592dec6a66cfad5688b2f7663f82ec480.tar.gz
python-urlgrabber-28afff5592dec6a66cfad5688b2f7663f82ec480.tar.bz2
python-urlgrabber-28afff5592dec6a66cfad5688b2f7663f82ec480.zip
Modify urlgrabber install directory
must name package name python3-urlgrabber, if so, it will be installed in dist-packages directory. But if you name it python-urlgrabber, it will be installed in site-paackages dir under pythone version Change-Id: I268bc9617ea55b1beb863b78c378dcefca0fa9cf Signed-off-by: biao716.wang <biao716.wang@samsung.com>
Diffstat (limited to 'debian')
-rw-r--r--debian/control6
-rw-r--r--debian/python-urlgrabber.install2
-rwxr-xr-xdebian/rules53
3 files changed, 13 insertions, 48 deletions
diff --git a/debian/control b/debian/control
index 1f8573c..67f13df 100644
--- a/debian/control
+++ b/debian/control
@@ -2,13 +2,13 @@ Source: python-urlgrabber
Section: devel
Priority: extra
Maintainer: Jong-Woo Chae <jonwoo.chae@samsung.com>
-Build-Depends: debhelper (>= 7.0.15), python3-dev, dh-python, python3-setuptools, python3-six, python3-pycurl
+Build-Depends: debhelper (>= 7.0.15), cdbs, python3, python-is-python3, python3-all, python3-dev, dh-python, python3-docutils, python3-six, python3-pycurl
Standards-Version: 4.1.0
Homepage: http://www.tizen.org
-Package: python-urlgrabber
+Package: python3-urlgrabber
Architecture: all
-Depends: ${python:Depends},
+Depends: ${python3:Depends},
python3-six,
python3-pycurl
Description: image creator for Linux distributions
diff --git a/debian/python-urlgrabber.install b/debian/python-urlgrabber.install
deleted file mode 100644
index 28207a6..0000000
--- a/debian/python-urlgrabber.install
+++ /dev/null
@@ -1,2 +0,0 @@
-debian/tmp/usr/lib/* /usr/lib
-debian/tmp/usr/bin/urlgrabber /usr/bin
diff --git a/debian/rules b/debian/rules
index e200318..79a8246 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,47 +1,14 @@
#!/usr/bin/make -f
+%:
+ dh $@ --with python3 --buildsystem=pybuild
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+override_dh_auto_install:
+ dh_auto_install
+ # remove unneeded documents installed by setup.py
+ -rm -rf $(CURDIR)/debian/python-urlgrabber/usr/share/doc/urlgrabber-*
+ #mkdir -p $(CURDIR)/debian/tmp
+ #python3 setup.py install --prefix=/usr --root=$(CURDIR)/debian/tmp
+override_dh_installchangelogs:
+ dh_installchangelogs ChangeLog
-build: build-stamp
-build-stamp:
- dh_testdir
- python3 setup.py build
-clean:
- dh_testdir
- dh_testroot
- rm -f build-stamp
- dh_clean
-
-install: build
- dh_testdir
- dh_testroot
- dh_clean -k
- dh_installdirs
-
- # Installing package
- mkdir -p $(CURDIR)/debian/tmp
- python3 setup.py install --prefix=/usr --root=$(CURDIR)/debian/tmp
-binary-indep: build install
- dh_testdir
- dh_testroot
- dh_installchangelogs
- dh_installdocs
- dh_install
- dh_installman
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
- dh_python3
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary-arch: build install
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install