summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorbiao716.wang <biao716.wang@samsung.com>2020-05-07 17:31:12 +0900
committerbiao716.wang <biao716.wang@samsung.com>2020-05-11 12:27:20 +0900
commit136d1e028cec5dcddc6ef6ac7302c794fda5f135 (patch)
treec3f7e881814418733213f16748187c56695636ae /debian/rules
parent0acddc325ed11e1d6cbed796a0a4adb4bdb67412 (diff)
downloadpython-urlgrabber-136d1e028cec5dcddc6ef6ac7302c794fda5f135.tar.gz
python-urlgrabber-136d1e028cec5dcddc6ef6ac7302c794fda5f135.tar.bz2
python-urlgrabber-136d1e028cec5dcddc6ef6ac7302c794fda5f135.zip
For Ubuntu 20.04, there is no python-urlgrabber given, so need to add this packages to support. Change-Id: I81ce0fe7ffb6b7ef6719e3de39b66ca47cec7abf Signed-off-by: biao716.wang <biao716.wang@samsung.com>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules47
1 files changed, 47 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..0fa0995
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,47 @@
+#!/usr/bin/make -f
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+ python setup.py build
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Installing package
+ mkdir -p $(CURDIR)/debian/tmp
+ python setup.py install --prefix=/usr --root=$(CURDIR)/debian/tmp
+binary-indep: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_install
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_python2
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary-arch: build install
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install