summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbiao716.wang <biao716.wang@samsung.com>2020-05-07 17:31:12 +0900
committerbiao716.wang <biao716.wang@samsung.com>2020-05-11 12:27:20 +0900
commit136d1e028cec5dcddc6ef6ac7302c794fda5f135 (patch)
treec3f7e881814418733213f16748187c56695636ae
parent0acddc325ed11e1d6cbed796a0a4adb4bdb67412 (diff)
downloadpython-urlgrabber-136d1e028cec5dcddc6ef6ac7302c794fda5f135.tar.gz
python-urlgrabber-136d1e028cec5dcddc6ef6ac7302c794fda5f135.tar.bz2
python-urlgrabber-136d1e028cec5dcddc6ef6ac7302c794fda5f135.zip
For Ubuntu 20.04, there is no python-urlgrabber given, so need to add this packages to support. Change-Id: I81ce0fe7ffb6b7ef6719e3de39b66ca47cec7abf Signed-off-by: biao716.wang <biao716.wang@samsung.com>
-rw-r--r--debian/changelog6
-rw-r--r--debian/compat1
-rw-r--r--debian/control16
-rw-r--r--debian/python-urlgrabber.install2
-rwxr-xr-xdebian/rules47
5 files changed, 72 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..1e95e82
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,6 @@
+python-urlgrabber (3.9.1) unstable; urgency=low
+
+ * add debian
+
+ -- Biao Wang <biao716.wang@samsung.com> Wed, 07 May 2020 10:09:30 +0800
+
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..a365ee5
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,16 @@
+Source: python-urlgrabber
+Section: devel
+Priority: extra
+Maintainer: Jong-Woo Chae <jonwoo.chae@samsung.com>
+Build-Depends: debhelper (>= 7.0.15), python-dev, python-pycurl
+Standards-Version: 3.9.1
+Homepage: http://www.tizen.org
+
+Package: python-urlgrabber
+Architecture: all
+Depends: ${python:Depends},
+ python-m2crypto | python3-m2crypto,
+ python-pycurl
+Description: image creator for Linux distributions
+ The tool createrep is used to ppfarm test
+
diff --git a/debian/python-urlgrabber.install b/debian/python-urlgrabber.install
new file mode 100644
index 0000000..28207a6
--- /dev/null
+++ b/debian/python-urlgrabber.install
@@ -0,0 +1,2 @@
+debian/tmp/usr/lib/* /usr/lib
+debian/tmp/usr/bin/urlgrabber /usr/bin
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..0fa0995
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,47 @@
+#!/usr/bin/make -f
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+ python setup.py build
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Installing package
+ mkdir -p $(CURDIR)/debian/tmp
+ python setup.py install --prefix=/usr --root=$(CURDIR)/debian/tmp
+binary-indep: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_install
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_python2
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary-arch: build install
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install