summaryrefslogtreecommitdiff
path: root/packaging/python-jenkinsapi.spec
diff options
context:
space:
mode:
Diffstat (limited to 'packaging/python-jenkinsapi.spec')
-rw-r--r--packaging/python-jenkinsapi.spec79
1 files changed, 79 insertions, 0 deletions
diff --git a/packaging/python-jenkinsapi.spec b/packaging/python-jenkinsapi.spec
new file mode 100644
index 0000000..0382121
--- /dev/null
+++ b/packaging/python-jenkinsapi.spec
@@ -0,0 +1,79 @@
+#
+# spec file for package python-jenkinsapi
+#
+# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+#
+# All modifications and additions to the file contributed by third parties
+# remain the property of their copyright owners, unless otherwise agreed
+# upon. The license for this file, and modifications and additions to the
+# file, is the same license as for the pristine package itself (unless the
+# license for the pristine package is not an Open Source License, in which
+# case the license is the MIT License). An "Open Source License" is a
+# license that conforms to the Open Source Definition (Version 1.9)
+# published by the Open Source Initiative.
+
+# Please submit bugfixes or comments via http://bugs.opensuse.org/
+#
+
+Name: python-jenkinsapi
+Version: 0.2.26
+Release: 0
+Summary: A Python API for accessing resources on a Jenkins continuous-integration server
+License: MIT
+Group: Development/Languages/Python
+Url: https://github.com/salimfadhley/jenkinsapi
+Source: https://pypi.python.org/packages/source/j/jenkinsapi/jenkinsapi-%{version}.tar.gz
+
+BuildRequires: python-setuptools
+
+%if 0%{?suse_version} || 0%{?fedora}
+BuildRequires: python-requests
+Requires: python-requests
+%endif
+
+%if 0%{?fedora} || 0%{?centos_ver}
+Requires: pytz
+%else
+Requires: python-pytz
+%endif
+
+%description
+Jenkins is the market leading continuous integration system, originally created
+by Kohsuke Kawaguchi.
+
+Jenkins (and It's predecessor Hudson) are useful projects for automating common
+development tasks (e.g. unit-testing, production batches) - but they are
+somewhat Java-centric. Thankfully the designers have provided an excellent and
+complete REST interface. This library wraps up that interface as more
+conventional python objects in order to make many Jenkins oriented tasks
+easier to automate.
+
+This library can help you:
+
+ * Query the test-results of a completed build
+ * Get a objects representing the latest builds of a job
+ * Search for artefacts by simple criteria
+ * Block until jobs are complete
+ * Install artefacts to custom-specified directory structures
+ * username/password auth support for jenkins instances with auth turned on
+ * Ability to search for builds by subversion revision
+ * Ability to add/remove/query Jenkins slaves
+ * Ability to add/remove/modify Jenkins views
+
+%prep
+%setup -q
+
+%build
+python setup.py build
+
+%install
+python setup.py install --prefix=%{_prefix} --root=%{buildroot}
+
+%files
+%defattr(-,root,root,-)
+%doc README.rst
+%{_bindir}/*
+%{python_sitelib}/*
+
+%changelog
+