summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
authorJoey Hess <joey@kitenet.net>2012-03-20 17:01:27 -0400
committerJoey Hess <joey@kitenet.net>2012-03-20 17:01:27 -0400
commit1b2912fbc690845ce47211df320ffb16c1a24322 (patch)
treef939e5747e280edab0571e072c6fa2cdfb083ec6 /Makefile.PL
parent63a89c7410e3387a35dc61fc4f4b3a05f3cd63cb (diff)
downloadpristine-tar-1b2912fbc690845ce47211df320ffb16c1a24322.tar.gz
pristine-tar-1b2912fbc690845ce47211df320ffb16c1a24322.tar.bz2
pristine-tar-1b2912fbc690845ce47211df320ffb16c1a24322.zip
move zgz/pit to pit
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.PL b/Makefile.PL
index fc8baf2..d11e396 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -19,14 +19,14 @@ extra_build: zgz/zgz pristine-tar.spec
pod2man -c pristine-bz2 pristine-bz2 > pristine-bz2.1
pod2man -c pristine-xz pristine-xz > pristine-xz.1
pod2man -c zgz zgz/zgz.pod > zgz.1
- make -C zgz/pit/suse-bzip2
+ make -C pit/suse-bzip2
ZGZ_SOURCES = zgz/zgz.c zgz/gzip/*.c zgz/old-bzip2/*.c
zgz/zgz: $(ZGZ_SOURCES)
gcc -Wall -O2 -o $@ $(ZGZ_SOURCES) -lz -DZGZ_LIB=\"$(ZGZ_LIB)\"
-SUSE_BZIP2_SOURCES = zgz/pit/suse-bzip2/*.c
-zgz/pit/suse-bzip2/suse-bzip2: $(SUSE_BZIP2_SOURCES)
+SUSE_BZIP2_SOURCES = pit/suse-bzip2/*.c
+pit/suse-bzip2/suse-bzip2: $(SUSE_BZIP2_SOURCES)
gcc -Wall -O2 -o $@ $(SUSE_BZIP2_SOURCES)
extra_install:
@@ -35,12 +35,12 @@ extra_install:
install pristine-tar pristine-gz pristine-bz2 pristine-xz zgz/zgz $(DESTDIR)/usr/bin
install -m 0644 *.1 $(DESTDIR)/usr/share/man/man1
install -d $(DESTDIR)$(ZGZ_LIB)/suse-bzip2
- install zgz/pit/suse-bzip2/bzip2 $(DESTDIR)$(ZGZ_LIB)/suse-bzip2
- install zgz/pit/suse-bzip2/libbz2* $(DESTDIR)$(ZGZ_LIB)/suse-bzip2
+ install pit/suse-bzip2/bzip2 $(DESTDIR)$(ZGZ_LIB)/suse-bzip2
+ install pit/suse-bzip2/libbz2* $(DESTDIR)$(ZGZ_LIB)/suse-bzip2
extra_clean: pristine-tar.spec
rm -f *.1 zgz/zgz
- make clean -C zgz/pit/suse-bzip2
+ make clean -C pit/suse-bzip2
pristine-tar.spec:
sed -i "s/Version:.*/Version: $$(perl -e '$$_=<>;print m/\((.*?)\)/'<debian/changelog)/" pristine-tar.spec