summaryrefslogtreecommitdiff
path: root/tests/hello-test/hello-1.0/hello.spec
diff options
context:
space:
mode:
Diffstat (limited to 'tests/hello-test/hello-1.0/hello.spec')
-rw-r--r--tests/hello-test/hello-1.0/hello.spec29
1 files changed, 29 insertions, 0 deletions
diff --git a/tests/hello-test/hello-1.0/hello.spec b/tests/hello-test/hello-1.0/hello.spec
new file mode 100644
index 000000000..d33216b99
--- /dev/null
+++ b/tests/hello-test/hello-1.0/hello.spec
@@ -0,0 +1,29 @@
+Summary: hello -- hello, world rpm
+Name: hello
+Version: 1.0
+Release: 1
+Group: Utilities
+License: GPL
+Source0: hello-1.0.tar.gz
+BuildRoot: /var/tmp/hello-root
+
+%description
+Simple rpm demonstration.
+
+%prep
+%setup -q
+
+%build
+make
+
+%install
+rm -rf $RPM_BUILD_ROOT
+mkdir -p $RPM_BUILD_ROOT/usr/local/bin
+make DESTDIR=$RPM_BUILD_ROOT install
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root)
+/usr/local/bin/hello