summaryrefslogtreecommitdiff
path: root/tests/data/SPECS/filedep.spec
diff options
context:
space:
mode:
Diffstat (limited to 'tests/data/SPECS/filedep.spec')
-rw-r--r--tests/data/SPECS/filedep.spec49
1 files changed, 49 insertions, 0 deletions
diff --git a/tests/data/SPECS/filedep.spec b/tests/data/SPECS/filedep.spec
new file mode 100644
index 000000000..d40305881
--- /dev/null
+++ b/tests/data/SPECS/filedep.spec
@@ -0,0 +1,49 @@
+Name: filedep
+Version: 1.0
+Release: 1
+Summary: Testing file dependencies
+License: GPL
+BuildArch: noarch
+
+%description
+%{summary}
+
+%prep
+%setup -q -T -c %{name}-%{version}
+
+
+%build
+cat << EOF >> foo
+#!/bin/sh
+cat /etc/foo.conf
+EOF
+
+cat << EOF >> bar
+#!/bin/f00f
+echo BUG
+EOF
+
+cat << EOF >> foo.conf
+hello there
+EOF
+
+cat << EOF >> README
+Some stuff, huh?
+EOF
+
+%install
+mkdir -p %{buildroot}/etc
+mkdir -p %{buildroot}/usr/bin
+mkdir -p %{buildroot}/usr/share/doc/filedep
+install -D -m 644 foo.conf %{buildroot}/etc
+install -D -m 755 foo bar %{buildroot}/usr/bin/
+install -D -m 644 README %{buildroot}/usr/share/doc/filedep
+
+%files
+/etc/*
+/usr/bin/*
+/usr/share/doc/filedep/
+
+
+%changelog
+