summaryrefslogtreecommitdiff
path: root/tests/data/SPECS/deptest.spec
diff options
context:
space:
mode:
Diffstat (limited to 'tests/data/SPECS/deptest.spec')
-rw-r--r--tests/data/SPECS/deptest.spec11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/data/SPECS/deptest.spec b/tests/data/SPECS/deptest.spec
index 7f2228f11..68b0fcbcc 100644
--- a/tests/data/SPECS/deptest.spec
+++ b/tests/data/SPECS/deptest.spec
@@ -10,9 +10,20 @@ BuildArch: noarch
%{?provs:Provides: %{provs}}
%{?cfls:Conflicts: %{cfls}}
%{?obs:Obsoletes: %{obs}}
+%{?recs:Recommends: %{recs}}
+%{?sugs:Suggests: %{sugs}}
+%{?sups:Supplements: %{sups}}
+%{?ens:Enhances: %{ens}}
+%{?buildreqs:BuildRequires: %{buildreqs}}
+%{?buildcfls:BuildConflicts: %{buildcfls}}
%description
%{summary}
+%install
+mkdir -p %{buildroot}/opt/
+echo FOO > %{buildroot}/opt/bar
+
%files
%defattr(-,root,root,-)
+/opt/bar