summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control3
-rwxr-xr-xdebian/rules3
2 files changed, 4 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 300fef560..a3a31bc4c 100644
--- a/debian/control
+++ b/debian/control
@@ -22,7 +22,8 @@ Build-Depends: debhelper,
libmagic-dev,
libelf-dev,
libdw-dev,
- libdb-dev
+ libdb-dev,
+ liblua5.1-dev
Maintainer: Markus Lehtonen <markus.lehtonen@linux.intel.com>
Standards-Version: 3.9.3
Homepage: http://rpm.org/
diff --git a/debian/rules b/debian/rules
index 30870a74f..594963018 100755
--- a/debian/rules
+++ b/debian/rules
@@ -10,7 +10,7 @@ CPPFLAGS += $(shell pkg-config --cflags nss)
override_dh_auto_configure:
dh_auto_configure -- --disable-dependency-tracking \
--libdir=/usr/lib/librpm-tizen \
- --without-lua \
+ --with-lua \
--without-acl \
--without-cap \
--enable-shared \
@@ -18,6 +18,7 @@ override_dh_auto_configure:
--with-external-db \
--build=${DEB_BUILD_GNU_CPU}-tizen-linux \
PYTHON_MODULENAME=$(python_mod_name) \
+ LUA_PKGCONFIG_NAME=lua5.1 \
CPPFLAGS="$(CPPFLAGS)"
override_dh_auto_install: