summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index edc0a24fd..188f880b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -115,6 +115,7 @@ if test X"$GCC" = Xyes ; then
case "$target" in
*-*-solaris*) LDFLAGS_STATIC="-static";;
*-*-hpux*) LDFLAGS_STATIC="-static";;
+ *-*-darwin*) LDFLAGS_STATIC="";; # Mac OS X does not do static binaries.
*-*-sysv5uw*) LDFLAGS_STATUS="-static";; # Unixware has no shared libthread.
*-*-*) LDFLAGS_STATIC="-all-static";;
esac