summaryrefslogtreecommitdiff
path: root/beecrypt/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'beecrypt/Makefile.am')
-rw-r--r--beecrypt/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/beecrypt/Makefile.am b/beecrypt/Makefile.am
index c241d0d47..5c49bc085 100644
--- a/beecrypt/Makefile.am
+++ b/beecrypt/Makefile.am
@@ -28,14 +28,18 @@
# 3. Interfaces removed (bad): Increment CURRENT, set AGE and REVISION to 0.
#
-LIBBEECRYPT_LT_CURRENT = 3
-LIBBEECRYPT_LT_AGE = 1
+LIBBEECRYPT_LT_CURRENT = 4
+LIBBEECRYPT_LT_AGE = 2
LIBBEECRYPT_LT_REVISION = 0
AUTOMAKE_OPTIONS = gnu check-news no-dependencies
SUBDIRS = docs gas masm mwerks tests
+SUFFIXES = .S
+.S.lo:
+ $(LTCOMPILE) -c -o $@ `test -f $< || echo '$(srcdir)/'`$<
+
BEECRYPT_OBJECTS = base64.lo beecrypt.lo blockmode.lo blockpad.lo blowfish.lo blowfishopt.lo dhaes.lo dldp.lo dlkp.lo dlpk.lo dlsvdp-dh.lo dsa.lo elgamal.lo endianness.lo entropy.lo fips180.lo fips180opt.lo fips186.lo hmac.lo hmacmd5.lo hmacsha1.lo hmacsha256.lo md5.lo memchunk.lo mp32.lo mp32barrett.lo mp32number.lo mp32opt.lo mp32prime.lo mtprng.lo rsa.lo rsakp.lo rsapk.lo sha256.lo timestamp.lo
BEECRYPT_JAVA_OBJECTS = javaglue.lo
@@ -50,7 +54,7 @@ libbeecrypt_la_LIBADD = blowfishopt.lo fips180opt.lo mp32opt.lo
libbeecrypt_la_LDFLAGS = -version-info $(LIBBEECRYPT_LT_CURRENT):$(LIBBEECRYPT_LT_REVISION):$(LIBBEECRYPT_LT_AGE)
-pkginclude_HEADERS = base64.h beecrypt.h blockmode.h blockpad.h blowfish.h blowfishopt.h dhaes.h dldp.h dlkp.h dlpk.h dlsvdp-dh.h elgamal.h endianness.h entropy.h fips180.h fips180opt.h fips186.h hmac.h hmacmd5.h hmacsha1.h hmacsha256.h md5.h memchunk.h mp32.h mp32barrett.h mp32number.h mp32opt.h mp32prime.h mtprng.h rsa.h rsakp.h rsapk.h sha256.h timestamp.h
+pkginclude_HEADERS = base64.h beecrypt.h blockmode.h blockpad.h blowfish.h blowfishopt.h dhaes.h dldp.h dlkp.h dlpk.h dlsvdp-dh.h dsa.h elgamal.h endianness.h entropy.h fips180.h fips180opt.h fips186.h hmac.h hmacmd5.h hmacsha1.h hmacsha256.h md5.h memchunk.h mp32.h mp32barrett.h mp32number.h mp32opt.h mp32prime.h mtprng.h rsa.h rsakp.h rsapk.h sha256.h timestamp.h
EXTRA_DIST = BENCHMARKS BUGS CONTRIBUTORS Doxyfile.in Doxyheader README.DLL README.WIN32 beecrypt.def beecrypt.mcp beecrypt.rc beecrypt.spec config.h config.gas.h config.win.h javaglue.h