summaryrefslogtreecommitdiff
path: root/rpmdb/Makefile.am
diff options
context:
space:
mode:
authorjbj <devnull@localhost>2002-05-02 22:16:30 +0000
committerjbj <devnull@localhost>2002-05-02 22:16:30 +0000
commit2b83d36c089f9e27e43e776d08e79d58ec2e6ba8 (patch)
treedff82d3f9e297e604e24fccdb11ee3d61f8687a2 /rpmdb/Makefile.am
parentcf2484ce1f2225e01b61dabb18a4d54e8fd6e375 (diff)
downloadlibrpm-tizen-2b83d36c089f9e27e43e776d08e79d58ec2e6ba8.tar.gz
librpm-tizen-2b83d36c089f9e27e43e776d08e79d58ec2e6ba8.tar.bz2
librpm-tizen-2b83d36c089f9e27e43e776d08e79d58ec2e6ba8.zip
- eliminate db1 support.
- fix: rpmdb iterator memory leak in python bindings. - fix: include <sys/time.h> for 6.2 python modules. - remove vestiges of mipseb arch (#62408). CVS patchset: 5414 CVS date: 2002/05/02 22:16:30
Diffstat (limited to 'rpmdb/Makefile.am')
-rw-r--r--rpmdb/Makefile.am10
1 files changed, 2 insertions, 8 deletions
diff --git a/rpmdb/Makefile.am b/rpmdb/Makefile.am
index beb4b61d4..d7d9dcf31 100644
--- a/rpmdb/Makefile.am
+++ b/rpmdb/Makefile.am
@@ -11,7 +11,7 @@ INCLUDES = \
-I$(top_srcdir)/popt \
@INCPATH@
-EXTRA_DIST = db3.c db1.c falloc.c
+EXTRA_DIST = db3.c
EXTRA_PROGRAMS = tjfn
@@ -21,7 +21,7 @@ tjfn_LDADD = librpmdb.la
pkgincdir = $(pkgincludedir)
pkginc_HEADERS = db.h header.h hdrinline.h rpmdb.h
-noinst_HEADERS = falloc.h fprint.h header_internal.h legacy.h rpmhash.h
+noinst_HEADERS = fprint.h header_internal.h legacy.h rpmhash.h
mylibpaths = \
-L$(top_builddir)/lib \
@@ -49,9 +49,6 @@ install-data-local:
sed -e "s|^dependency_libs='|& -lrpmio|" < librpmdb.la > .librpmdb.la && \
mv .librpmdb.la librpmdb.la
-falloc.lo: falloc.c $(top_srcdir)/system.h $(top_srcdir)/rpmio/rpmio.h falloc.h
- $(LIBTOOL) --mode=compile $(COMPILE) -c $<
-
tagtbl.c: $(top_srcdir)/lib/rpmlib.h
@echo '#include "system.h"' > $@
@echo '#include "lib/rpmlib.h"' >> $@
@@ -93,6 +90,3 @@ lclint:
tdbi: librpmdb.la tdbi.o
$(LINK) -all-static $@.o $< $(mylibpaths) $(mylibs) $(LIBS)
-
-tfalloc: librpmdb.la tfalloc.o
- $(LINK) -all-static $@.o $< $(mylibpaths) $(mylibs) $(LIBS)