summaryrefslogtreecommitdiff
path: root/packaging/python-rpm.spec
diff options
context:
space:
mode:
authorRonan Le Martret <ronan@fridu.net>2013-11-07 09:25:19 +0100
committerGerrit Code Review <gerrit@review.vlan103.tizen.org>2013-11-15 12:25:25 -0800
commit12a4a4ffa22eeda92bd30f954c8d59bd99e8d599 (patch)
tree333b45dd0e7fe4d70b0505cea66c9a559cb46b7d /packaging/python-rpm.spec
parenta95d28bbba86712bf7332bd764e24be72cedd0f9 (diff)
downloadlibrpm-tizen-12a4a4ffa22eeda92bd30f954c8d59bd99e8d599.tar.gz
librpm-tizen-12a4a4ffa22eeda92bd30f954c8d59bd99e8d599.tar.bz2
librpm-tizen-12a4a4ffa22eeda92bd30f954c8d59bd99e8d599.zip
- solve bug PTREL-155, build python-rpm.
Change-Id: Idffe011bde3623d20c647aad8c6bac70b07f83f5 Signed-off-by: Ronan Le Martret <ronan@fridu.net>
Diffstat (limited to 'packaging/python-rpm.spec')
-rw-r--r--packaging/python-rpm.spec9
1 files changed, 7 insertions, 2 deletions
diff --git a/packaging/python-rpm.spec b/packaging/python-rpm.spec
index f27dd1d37..b2ff0dd0b 100644
--- a/packaging/python-rpm.spec
+++ b/packaging/python-rpm.spec
@@ -24,7 +24,8 @@ BuildRequires: libxml2-devel
BuildRequires: libattr-devel
BuildRequires: pkgconfig(libsmack)
Requires: rpm = %{version}
-%{expand:%(sed -n -e '/^Source0:/,/^BuildRoot:/p' <%_sourcedir/rpm.spec)}
+%{expand:%(sed -n -e '/^### SOURCES BEGIN ###/,/^### SOURCES END ###/p' <%_sourcedir/rpm.spec)}
+Source0: rpm-%{version}.tar.bz2
%global with_python 2
%description
@@ -36,7 +37,11 @@ This package should be installed if you want to develop Python programs
that will manipulate RPM packages and databases.
%prep
-%{expand:%(sed -n -e '/^%%prep/,/^%%install/p' <%_sourcedir/rpm.spec | sed -e '1d' -e '$d')}
+%setup -q -n rpm-%{version}
+%{expand:%(sed -n -e '/^### PREP BEGIN ###/,/^### PREP END ###/p' <%_sourcedir/rpm.spec)}
+
+%build
+%{expand:%(sed -n -e '/^### BUILD BEGIN ###/,/^### BUILD END ###/p' <%_sourcedir/rpm.spec)}
%install
mkdir -p %{buildroot}%{_prefix}/lib