summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorSteve Lawrence <slawrence@tresys.com>2010-06-21 17:04:39 -0400
committerPanu Matilainen <pmatilai@redhat.com>2010-06-22 11:12:43 +0300
commit04bdec775ac56c7673f87257306b23536a954474 (patch)
tree9b3209bfd02f9bee5311a7d9952e8122ed4be1e0 /lib/Makefile.am
parent2fd0913a6abd91389a3f1498ef9c4b2c6c72bff1 (diff)
downloadlibrpm-tizen-04bdec775ac56c7673f87257306b23536a954474.tar.gz
librpm-tizen-04bdec775ac56c7673f87257306b23536a954474.tar.bz2
librpm-tizen-04bdec775ac56c7673f87257306b23536a954474.zip
Add plugin calling support
This patch adds a simple plugin system that makes simple problems easy to solve, and difficult problems, such as SELinux, possible. When the transaction gets to the point where a collection action should occur, it expands a macro of the form %__collection_<collection name> to get the path to a plugin and any additional options. The plugin is dlopen'ed, and the appropriate function is called in the plugin, with the additional arguments passed in. This also adds a --nocollections option to disable performing Collection actions.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index c308bc658..1357c7c5b 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -33,7 +33,8 @@ librpm_la_SOURCES = \
rpmvercmp.c signature.c signature.h transaction.c \
verify.c rpmlock.c rpmlock.h misc.h \
rpmscript.h rpmscript.c legacy.c merge.c \
- rpmliblua.c rpmliblua.h rpmchroot.c rpmchroot.h
+ rpmliblua.c rpmliblua.h rpmchroot.c rpmchroot.h \
+ collections.h
librpm_la_LDFLAGS = -version-info 1:0:0