summaryrefslogtreecommitdiff
path: root/fileattrs/Makefile.am
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2010-03-23 16:21:27 +0200
committerPanu Matilainen <pmatilai@redhat.com>2010-03-23 16:32:46 +0200
commit8c7e53ec80e84f48bfc67181f3d5dd81ecdb7523 (patch)
tree1777f57f13aaa83b3e1c77ba66f2d8e29547e8e1 /fileattrs/Makefile.am
parent7628c31bb9688c04561bd46c840ec9437fab4f67 (diff)
downloadlibrpm-tizen-8c7e53ec80e84f48bfc67181f3d5dd81ecdb7523.tar.gz
librpm-tizen-8c7e53ec80e84f48bfc67181f3d5dd81ecdb7523.tar.bz2
librpm-tizen-8c7e53ec80e84f48bfc67181f3d5dd81ecdb7523.zip
First take at pluggable file attribute + dependency extraction system
- move most of the hardwired classification logic from rpmfc C-code to macro-based configuration, supporting drop-in addition of arbitrary new attributes + dependency extractors based on regex matching of libmagic file types and paths - just the initial rough conversion of our built-in dependency types, various open questions + todo-items remain, plus likely fair amount of more-or-less subtle breakage
Diffstat (limited to 'fileattrs/Makefile.am')
-rw-r--r--fileattrs/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/fileattrs/Makefile.am b/fileattrs/Makefile.am
new file mode 100644
index 000000000..379737a4f
--- /dev/null
+++ b/fileattrs/Makefile.am
@@ -0,0 +1,11 @@
+# Makefile for rpm file attributes
+
+include $(top_srcdir)/rpm.am
+
+fattrsdir = $(rpmconfigdir)/fileattrs
+
+fattrs_DATA = \
+ desktop elf font libtool perl perllib pkgconfig python \
+ ocaml script
+
+EXTRA_DIST = $(fattrs_DATA)