summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMarkus Lehtonen <markus.lehtonen@linux.intel.com>2012-12-18 13:56:39 +0200
committerMarkus Lehtonen <markus.lehtonen@linux.intel.com>2014-06-11 17:48:02 +0300
commitff18f94a0e1ad4a50b9308823b3633f9dd92db26 (patch)
treebec4bad427ec23e949e733a82b0e83bfc37bc35d /debian/rules
parente6b20d86c02b2be44283c166a9e87d5e4a7225c2 (diff)
downloadlibrpm-tizen-ff18f94a0e1ad4a50b9308823b3633f9dd92db26.tar.gz
librpm-tizen-ff18f94a0e1ad4a50b9308823b3633f9dd92db26.tar.bz2
librpm-tizen-ff18f94a0e1ad4a50b9308823b3633f9dd92db26.zip
packaging: add Debian packaging
Signed-off-by: Markus Lehtonen <markus.lehtonen@linux.intel.com>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules28
1 files changed, 28 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 000000000..a1fdc32e9
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,28 @@
+#!/usr/bin/make -f
+
+python_mod_name := rpm_tizen
+
+CPPFLAGS += $(shell pkg-config --cflags nss)
+
+%:
+ dh $@ --with python2,autoreconf,autotools_dev
+
+override_dh_auto_configure:
+ dh_auto_configure -- --disable-dependency-tracking \
+ --libdir=/usr/lib/librpm-tizen \
+ --without-lua \
+ --without-acl \
+ --without-cap \
+ --enable-shared \
+ --enable-python \
+ --with-external-db \
+ --build=${DEB_BUILD_GNU_CPU}-tizen-linux \
+ PYTHON_MODULENAME=$(python_mod_name) \
+ CPPFLAGS="$(CPPFLAGS)"
+
+override_dh_auto_install:
+ dh_auto_install --destdir=debian/tmp
+
+override_dh_python2:
+ dh_python2 --no-guessing-versions
+