summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPanu Matilainen <pmatilai@redhat.com>2010-12-22 14:58:11 +0200
committerPanu Matilainen <pmatilai@redhat.com>2010-12-22 14:58:11 +0200
commit454859f3cbe6f59cbf6d5905fe469d3bf64adf4a (patch)
treed1af9a6952b040a2a11458bb29e4b9eb2a444cb8 /configure.ac
parentd10b40301188f1b00cbdaf49b1c09786d546ede0 (diff)
downloadlibrpm-tizen-454859f3cbe6f59cbf6d5905fe469d3bf64adf4a.tar.gz
librpm-tizen-454859f3cbe6f59cbf6d5905fe469d3bf64adf4a.tar.bz2
librpm-tizen-454859f3cbe6f59cbf6d5905fe469d3bf64adf4a.zip
Only sepolicy-plugin needs linking to libsemanage
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9254dc626..2aa190bb7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -599,6 +599,7 @@ AS_IF([test "$with_selinux" = yes],[
AC_MSG_ERROR([--with-selinux given, but selinux/label.h not found])
])
+ dnl FIXME: semanage is only needed for the sepolicy plugin
AC_CHECK_HEADER([semanage/semanage.h],[
save_LIBS="$LIBS"
AC_CHECK_LIB([semanage],[semanage_begin_transaction],[],[
@@ -637,9 +638,11 @@ AS_IF([test "$with_selinux" = yes],[
AS_IF([test "$with_selinux" = yes],[
AC_DEFINE(WITH_SELINUX, 1, [Build with selinux support?])
- WITH_SELINUX_LIB="-lselinux -lsemanage"
+ WITH_SELINUX_LIB="-lselinux"
+ WITH_SEMANAGE_LIB="-lsemanage"
])
AC_SUBST(WITH_SELINUX_LIB)
+AC_SUBST(WITH_SEMANAGE_LIB)
AM_CONDITIONAL(SELINUX,[test "$with_selinux" = yes])
# libcap