summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorbiao716.wang <biao716.wang@samsung.com>2023-06-01 14:30:32 +0900
committerbiao716.wang <biao716.wang@samsung.com>2023-08-04 11:14:29 +0900
commite1697335851f3ef2b7ef911a162063f59a9d6f66 (patch)
treef46470ddebefa2e6f3e5fb96a5e166e22dae13c7 /configure.ac
parente806b67f7bf4458450f5d951262ec0aedf7a4a19 (diff)
downloadlibrpm-tizen-sandbox/wangbiao/py3-version.tar.gz
librpm-tizen-sandbox/wangbiao/py3-version.tar.bz2
librpm-tizen-sandbox/wangbiao/py3-version.zip
fix build error for opensuse with python3.xsandbox/wangbiao/py3-version
For opensuse154, the lib name is libpython3.6m , there is 'm' behind version. Change-Id: Ie51d20658d8799f3f1a0930a1a12527540999346 Signed-off-by: biao716.wang <biao716.wang@samsung.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index a47b319f5..acdc5204c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -127,7 +127,7 @@ AC_MSG_CHECKING(old version of patch)
AC_PATH_PROG(__PERL, perl, /usr/bin/perl, $MYPATH)
AC_PATH_PROG(__PGP, pgp, /usr/bin/pgp, $MYPATH)
-AC_PATH_PROG(__PYTHON, python, /usr/bin/python, $MYPATH)
+AC_PATH_PROG(__PYTHON, python, /usr/bin/python3, $MYPATH)
AC_PATH_PROG(__RM, rm, /bin/rm, $MYPATH)
AC_PATH_PROG(__RSH, rsh, /usr/bin/rsh, $MYPATH)
AC_PATH_PROG(__SED, sed, /bin/sed, $MYPATH)
@@ -550,9 +550,10 @@ AS_IF([test "$enable_python" = yes],[
])
CPPFLAGS="$save_CPPFLAGS"
save_LIBS="$LIBS"
- AC_SEARCH_LIBS([Py_Main],[python${PYTHON_VERSION} python],[
+
+ AC_SEARCH_LIBS([Py_Main],[python${PYTHON_VERSION} python3.6m],[
WITH_PYTHON_LIB="$ac_res"
- ],[AC_MSG_ERROR([missing python library])
+ ],[AC_MSG_ERROR([missing python library, ${PYTHON_VERSION} vvv${PYTHON_ABI}vvv])
])
LIBS="$save_LIBS"
])