summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPanu Matilainen <Panu Matilainen pmatilai@redhat.com>2011-07-08 10:31:34 +0300
committerPanu Matilainen <Panu Matilainen pmatilai@redhat.com>2011-07-08 10:31:34 +0300
commit4b7e6cb79f5073fc42ae98e153668e574ebe0388 (patch)
treef35f425734202f3c650c525c7a61d6f9faf2a492 /configure.ac
parent9958e535fff7bd5d65fd4b68fab3fc1d40158f56 (diff)
downloadlibrpm-tizen-4b7e6cb79f5073fc42ae98e153668e574ebe0388.tar.gz
librpm-tizen-4b7e6cb79f5073fc42ae98e153668e574ebe0388.tar.bz2
librpm-tizen-4b7e6cb79f5073fc42ae98e153668e574ebe0388.zip
zlib is mandatory, fail at configure if missing + remove conditionals
- Unlike bz2 and xz/lz, zlib compression is not tracked by any rpmlib feature and is part of the original package format really, zlib simply must be always present.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9e5d112c7..e1aa2e0f8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -172,6 +172,8 @@ AC_CHECK_HEADERS([zlib.h],[
dnl zlib-1.0.4 has not gzseek
AC_CHECK_LIB(${zlib}, gzseek, [AC_DEFINE(HAVE_GZSEEK, 1, [Define as 1 if your zlib has gzseek()])])
])
+],[
+ AC_MSG_ERROR([missing required header zlib.h])
])
AC_SUBST(WITH_ZLIB_INCLUDE)